Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an error that seems to have been reported before but not solved by previous answers. When I try to log in as my primary account, I get a blackscreen and go back to the login menu. I am very confident this is due to me foolishly changing my password via terminal ("sudo passwd [user]") as I have been able to log in successfully, not to mention this started happening immediately after I restarted the computer from doing that. I would think I lost rights, or something like that.

What I have tried ("user" is symbolizing my actual account name, not the folder in root):

sudo chown -R user:user /home/user/
sudo chmod a+wt /tmp
sudo chown user:user .Xauthority

Any help is greatly appreciated. Thank you.

P.S. Attempting to change my password via grub terminal gives something about a missing keyring...

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.