Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 12.04 LTS, and while experimenting with the software, I have encountered this problem:

I learnt that ctrl + alt + F1~F6 can bring me to the terminal (Or was it a virtual terminal? I am not entirely sure on that). Either way, the terminal works, but the real problem starts when I try to exit the terminal with alt + F7 to get back to my GUI. The screen starts flashing in black and white, where I could only force reboot with the power button.

Generally I can still access the GUI by restarting, but the bug happens when I switch between the GUI and the terminal.

I also notice that returning from suspend also results in the same error.

I am completely new to Linux, especially to its command line, I would appreciate that you would keep the answers plain and easy.

share|improve this question
    
I have exactly the same problem. I should add that as a graphic driver I have Gallium 0.4 on AMD RV710(, and linux 3.5.0-26-generic. –  fioan89 Mar 25 '13 at 21:11

2 Answers 2

"I also notice that returning from suspend also results in the same error."

I have same problem.

My main concern was inability to use suspend (I don't really have reason to use Ctrl+Alt+FX terminals).

Anyway I turned off option that turns off my screen after being inactive for some time and it turned out that now I am able to suspend.

So if you want to avoid those flashes while "waking up" from suspended state, just turn option turn screen of when inactive off.

At least it worked for me. Its not solution for the problem but it makes problem bearable

share|improve this answer

Open terminal and run these commands

Remove existing xorg using the following command

sudo apt-get remove --purge xserver-xorg

Install xorg using the following command

sudo apt-get install xserver-xorg

Reconfigure xorg using the following command

sudo dpkg-reconfigure xserver-xorg

saw it one one website, fixed problem for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.