Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have issue with NetBeans:

everything worked fine but I've just tried to run my CUDA programs on Linux Ubuntu 12.10 in NetBeans and I get error:

dist/Debug/GNU-Linux-x86/my_cuda_1: error while loading shared libraries: cannot open shared object file: No such file or directory

RUN FAILED (exit value 127, total time: 191ms)

the projects can build: compile + link without problems, I can also run it from commandline but if I try run it from NetBeans I get this error. I was able to run it few minutes ago, what might happened?

I have added file my_lib to containing such text:


can it be a link issue -> there are two libs in cuda/lib (link) and (link) and (shared lib) why it complains about .so.5.0? mayve link like: sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/ is necessary

it is related to link to shared library I think

root@comp:# echo $LD_LIBRARY_PATH /usr/lib/nvidia-current:/usr/local/cuda-5.0/lib::/usr/local/cuda-5.0/lib64:/lib

this :: is this a problem?

share|improve this question

1 Answer 1

up vote 1 down vote accepted


add to the Project->Properties->Environment

Value: $LD_LIBRARY_PATH:/usr/lib/nvidia-current:/usr/local/cuda-5.0/lib:/usr/local/cuda-5.0/lib64:/lib

but I don't know what happened as it worked before

share|improve this answer
Start working thanks – Dawid Drozd Jan 12 '14 at 10:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.