Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Cant Log in after suspend

After i click suspend my PC goes to sleep mode and everything is fine. But when i click the power button i get a black screen with all kinds of awful colored lines all over it. It must be the log in screen but i can't type my password the keyboard does not work. After a few seconds the monitor shuts down and the only way to fix this is a hard reset. Does anyone have a similar problem ?

I have installed the nVidia drivers by opening a program called Additional Drivers and it is activated cause i see a green light at the bottom.

I have Ubuntu 12.4 LTS 64 Bit. My CPU Type is QuadCore Intel Core i7-2600, 3400 MHz. My Main Memory is 12268 MB. And my Graphic Card is NVIDIA GeForce GT 545 .

Here is the screen i get when i try to wake up PC from Suspend: screen after resuming from suspend

Ubuntu Logo missing on start up

Also when i start my PC and choose Ubuntu from the grub menu i don't see the Ubuntu Logo loading, just a purple screen and after a few seconds i get into Ubuntu. On my other PC i see Ubuntu logo which is loading. Why is that ?

Ubuntu Logo on Start Up

Hear are my partitions my partitions

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I managed to solve the problem with resuming from suspend. First in the Additional Drivers Program i installed a beta experimental version of nVidia.

Then i did this in myterminal:

  • sudo apt-get install v86d
  • gksu gedit /etc/default/grub

Here i replaced GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with this one: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"

Also i replaced #GRUB_GFXMODE=640x480 with this one: GRUB_GFXMODE=1280x1024

  • gksu gedit /etc/initramfs-tools/modules

I added the following line at the end of the file: uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap

  • echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
  • sudo update-grub2
  • sudo update-initramfs -u
  • Reboot Ubuntu

Both problems are now solved. The Boot Splash Screen and the resume from Suspend. But now i get the feeling that the system is booting a little longer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.