Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a WiFi card on my Ubuntu 12.10 desktop box, the name of that card is wlan0, when I try to manually set up wlan0 to use DHCP from /etc/network/interfaces as showing below:

auto wlan0
iface wlan0 inet dhcp

Ubuntu can't boot.

However if using network-manager applet to setup dhcp for wlan0, wlan0 works well. I wonder what is wrong with my current setting for wlan0 card.

How to solve this ?

Any comments will be highly appreciated.

share|improve this question
    
I hope you set it up like this: paste.ubuntu.com/5607878 Why do you want to use manual methods instead of Network Manager? As you have seen, NM works well. –  chili555 Mar 12 '13 at 14:46
    
Yes I set correctly it as showing on your paste.ubuntu.com/5607878. –  Kevin Liao Mar 12 '13 at 15:36
    
The reason I want to switch to manually set up is I need create default gateway for wlan0 something like this "route add default gw 10.124.46.1", I don't know how to implement in Network Manager. Please give me your comments. Thanks. –  Kevin Liao Mar 12 '13 at 15:38
    
Does 10.124.46.1 have an SSID? Usually you specify the network you want to connect to by filling in the SSID. Is this an ad-hoc computer-to-computer connection? Is there encryption? –  chili555 Mar 12 '13 at 15:44
    
Usually any gateway device you use (router, cable modem, et.al.) will give out it's addy via dhcp. If you're device at 10.124.46.1 has a dhcp server this should be very "plug n play" if not I suggest that you enable dhcp server on that device. Save yourself some headaches. P.S. We need more info: What is the other device? Why is network-manager not something you want? –  Jason Mar 12 '13 at 16:27
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.