Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.10 with many headaches, and as soon as I got it up and running I ran the update utility through apt-get and proceeded to upgrade. Along the way, though, it got to what appeared to be the end, and said "done," but it didn't finish, meaning it didn't return to command input. So I tried closing it and restarting, and now Ubuntu tells me it has internal errors, and trying to run apt-get update again tells me this:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So I run the command and this happens:

sudo dpkg --configure -a
Setting up memtest86+ (4.20-1.1ubuntu2.1) ...
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.5.0-17-generic
Found initrd image: /boot/initrd.img-3.5.0-17-generic
Found memtest86+ image: /memtest86+.bin
grub-probe: error: cannot find a GRUB drive for /dev/sdd2.  Check your device.map.
Found Windows 7 (loader) on /dev/sdb1
done

And I have the same problem. How can I get my updates to work properly?

share|improve this question
    
I'll note additionally that any attempts to use apt after closing this terminal window tell me that dpkg is in use and that I can't do anything. –  ssb Mar 12 '13 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.