Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have trouble connecting with my wifi at work. Here are the symptoms:

  • When I connect, it usually succeeds (about 75% of the time).
  • When I am connected, the connection stays online for about 15min to 45min, and then drops for a few minutes, sometimes more, and it repeats.
  • When I am disconnected, the signal bar is at full (whereas when I am connected I have 3/4 bars.
  • Most of the time I cannot control the wifi UI (in the wifi dropdown, clicking disconnect does nothing appart from closing the menu, selecting another network does nothing, and the"other network" submenu is empty and displays a tiny box.
  • Some networks are more unstable than others

I cannot try to plug in ethernet as it's not available at work. At home, I sometimes have this problem, but it's very rare (something like 5% of the time) At home, I experience similar problems when connecting with ethernet.

So I guess there is a problem with my ethernet/wifi driver, but I don't know how to trouleshoot that on ubuntu.

I previously had a windows 7 OS on this machine, and I never had such issues. No one else is experiencing such issues at work.

My system is up to date (update manager says that there are no updates to install) My OS: ubuntu 12.04 LTS, 32-bit Hardware: samsung series 9 15inch, NP900X4C

I have took the habit of working with a connection that randomly drops, but every so often it breaks for longer when I really need it. So I'll try to fix it.

Can you walk through some debbuging, as don't know how to do it on this system ?


Maybe that helps:

    $ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        E8:03:9A:AB:A8:69

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0  [Wifi_Neuilly_LAB] --------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlwifi
  State:             connected
  Default:           yes
  HW Address:        C4:85:08:0C:41:3A

  Capabilities:
    Speed:           6 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    FreeWifi_secure: Infra, 62:98:5C:C9:44:F6, Freq 2462 MHz, Rate 54 Mb/s, Strength 49 WPA Enterprise
    freeboxf2i:      Infra, 62:98:5C:C9:44:F4, Freq 2462 MHz, Rate 54 Mb/s, Strength 47 WPA
    FreeWifi_secure: Infra, D2:34:1A:95:65:C2, Freq 2462 MHz, Rate 54 Mb/s, Strength 30 WPA Enterprise
    FreeboxELYOR:    Infra, D2:34:1A:95:65:C0, Freq 2462 MHz, Rate 54 Mb/s, Strength 35 WEP
    FreeWifi:        Infra, 62:98:5C:C9:44:F5, Freq 2462 MHz, Rate 54 Mb/s, Strength 49
    FreeWifi:        Infra, D2:34:1A:95:65:C1, Freq 2462 MHz, Rate 54 Mb/s, Strength 35
    Wifi_Neuilly_Ville: Infra, 00:1A:1E:08:4A:60, Freq 2437 MHz, Rate 54 Mb/s, Strength 54 WPA2 Enterprise
    Wifi_Neuilly_LAB:Infra, 00:1A:1E:08:4A:61, Freq 2437 MHz, Rate 54 Mb/s, Strength 52
    Wifi_Neuilly_LAB:Infra, 00:1A:1E:0A:78:61, Freq 2437 MHz, Rate 54 Mb/s, Strength 70
    ALCYANESAS:      Infra, 00:1B:2F:00:7D:AC, Freq 2472 MHz, Rate 54 Mb/s, Strength 40 WPA WPA2
    Wifi_Neuilly_Ville: Infra, 00:1A:1E:0A:78:60, Freq 2437 MHz, Rate 54 Mb/s, Strength 80 WPA2 Enterprise
    Wifi_Neuilly_LAB:Infra, 00:1A:1E:08:44:A1, Freq 2462 MHz, Rate 54 Mb/s, Strength 27
    default:         Infra, 00:50:7F:AC:31:70, Freq 2412 MHz, Rate 54 Mb/s, Strength 35 WPA
    Wifi_Neuilly_Ville: Infra, 00:1A:1E:08:44:A0, Freq 2462 MHz, Rate 54 Mb/s, Strength 32 WPA2 Enterprise
    IEF2I:           Infra, 00:50:7F:AC:31:71, Freq 2412 MHz, Rate 54 Mb/s, Strength 37 WPA2
    *Wifi_Neuilly_LAB: Infra, 00:1A:1E:0A:78:69, Freq 5700 MHz, Rate 54 Mb/s, Strength 77
    Wifi_Neuilly_Ville: Infra, 00:1A:1E:FD:5B:20, Freq 2412 MHz, Rate 54 Mb/s, Strength 40 WPA2 Enterprise
    Wifi_Neuilly_Ville: Infra, 00:1A:1E:08:4A:68, Freq 5500 MHz, Rate 54 Mb/s, Strength 39 WPA2 Enterprise
    Wifi_Neuilly_LAB:Infra, 00:1A:1E:FD:5B:21, Freq 2412 MHz, Rate 54 Mb/s, Strength 37
    Wifi_Neuilly_LAB:Infra, 00:1A:1E:08:4A:69, Freq 5500 MHz, Rate 54 Mb/s, Strength 37
    NEUF_FB60:       Infra, 00:25:15:53:FB:64, Freq 2462 MHz, Rate 54 Mb/s, Strength 20 WPA
    SFR WiFi Public: Infra, B2:25:15:53:FB:65, Freq 2462 MHz, Rate 54 Mb/s, Strength 30
    Wifi_Neuilly_Ville: Infra, 00:1A:1E:FD:5B:28, Freq 5240 MHz, Rate 54 Mb/s, Strength 42 WPA2 Enterprise
    Wifi_Neuilly_LAB:Infra, 00:1A:1E:FD:5B:29, Freq 5240 MHz, Rate 54 Mb/s, Strength 42

  IPv4 Settings:
    Address:         172.20.2.26
    Prefix:          24 (255.255.255.0)
    Gateway:         172.20.2.254

    DNS:             172.20.2.254
share|improve this question
    
If it's an option for you, you can switch WiFi-cards in your laptop (mind if the Bios picks it up) for tests/ You can easilly find such cards miniPci second hand or brand new for peanuts. Maybe it could solve your problem without serious hastle with Ubuntu. Just a suggestion as a tip. –  Joris Donders Mar 12 '13 at 10:53
    
@JorisDonders Thanks for the tip. But as everything was working fine before, I think this can be solved on the software side... –  pinouchon Mar 12 '13 at 11:08
    
The network panel becomes unresponsive after a while for me too, I'm on 11.04. It also randomly connects when I don't want it to. –  Will Sheppard Apr 3 '13 at 15:07
    
Update: My computer (Samsung series 9 15inch) has died: it doesn't show up the bios or anything on startup, only the blue power led turns on. So maybe it was an hardware problem. Now I have a mac. (Sigh). –  pinouchon Apr 3 '13 at 15:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.