Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not sure what I did but as of this morning ubuntu on my imac has been auto logging in as gdm. I've tried the following remedies

  1. reinstall lightdm and ubuntu-desktop
  2. delete auto-login and set auto-login-guest=false on /etc/gdm/custom.conf and /etc/lightdm/lightdm.conf
  3. set up a new user with identical permissions to my old one and try and re-login with that.
  4. upgrade to roaring-ringtail beta (I have nautilus 3.7.1 installed and I wondered if this might have had something to do with it)

Wierdly one of the effects is that when I open a terminal it opens and then disappears. I have to go to the tty terminal using Alt-Ctrl-f2 to make any changes. Not too sure what files I need to post to help resolve this, but would appreciate any help.

edit: the home directory for gdm is /var/lib/gdm (not sure if this helps)

share|improve this question
add comment

1 Answer 1

For gdm the following options in /etc/gdm/custom.conf are controlling the automatic login:

TimedLoginEnable=true
TimedLogin=userName
TimedLoginDelay=15

AutomaticLoginEnable=true
AutomaticLogin=userName

To disable the automatic login, ensure that TimedLoginEnable and AutomaticLoginEnable are switched to false.

share|improve this answer
    
Thanks for replying @H.-DirkSchmitt. I've tried that and unfortunately it has no effect. The machine still boots up and auto logs in as gdm. Likewise changing it back to true and setting AutomaticLogin=myusername and TimedLogin=myusername has no effect –  Tahnoon Pasha Mar 12 '13 at 10:26
    
@TahnoonPasha Do you really use gdm. I`m a little bit confused by mentioning in your question lightdm. –  H.-Dirk Schmitt Mar 12 '13 at 10:28
    
Hi @H.-DirkSchmitt no I don't. I loaded gnome-3 when I was trying to install nautilus 3.7.5 but I have no real need for it. It just seems to be a permission class that is auto-loading itself as the user –  Tahnoon Pasha Mar 12 '13 at 10:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.