Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

here is my configuration: - S.O.: Ubuntu 12.04 - Kernel: 3.5.0-25 - Laptop: Sony Vaio VGN-FZ21E - WiFi car: Intel PRO/Wireless 3945ABG [Golan] - driver: iwl3945

After suspension my WiFi isn't working, even restarting network or reloading modules. It seems simply that the card is switched off and Ubuntu cannot communicate with it. I thought this as I had a look into /var/log/syslog and I've found this:

Mar 11 17:33:25 pablo-laptop kernel: [ 5225.608061] sky2 0000:08:00.0: eth0: disabling interface
Mar 11 17:33:25 pablo-laptop kernel: [ 5225.619189] sky2 0000:08:00.0: eth0: enabling interface
Mar 11 17:33:25 pablo-laptop kernel: [ 5225.619706] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Mar 11 17:33:26 pablo-laptop kernel: [ 5226.637161] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:26 pablo-laptop kernel: [ 5226.637171] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:26 pablo-laptop kernel: [ 5226.764525] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:26 pablo-laptop kernel: [ 5226.764531] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:26 pablo-laptop kernel: [ 5226.891926] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:26 pablo-laptop kernel: [ 5226.891932] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:26 pablo-laptop kernel: [ 5227.019321] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:26 pablo-laptop kernel: [ 5227.019326] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:26 pablo-laptop kernel: [ 5227.146696] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:26 pablo-laptop kernel: [ 5227.146701] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:26 pablo-laptop kernel: [ 5227.147044] iwl3945 0000:06:00.0: Unable to initialize device after 5 attempts.
Mar 11 17:33:31 pablo-laptop kernel: [ 5231.965726] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:31 pablo-laptop kernel: [ 5231.965735] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:31 pablo-laptop kernel: [ 5232.093091] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:31 pablo-laptop kernel: [ 5232.093097] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:31 pablo-laptop kernel: [ 5232.220442] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:31 pablo-laptop kernel: [ 5232.220447] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:32 pablo-laptop kernel: [ 5232.347782] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:32 pablo-laptop kernel: [ 5232.347787] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:32 pablo-laptop kernel: [ 5232.475196] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:32 pablo-laptop kernel: [ 5232.475201] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:32 pablo-laptop kernel: [ 5232.475555] iwl3945 0000:06:00.0: Unable to initialize device after 5 attempts.
Mar 11 17:33:36 pablo-laptop kernel: [ 5236.981027] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:36 pablo-laptop kernel: [ 5236.981040] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:36 pablo-laptop kernel: [ 5237.111258] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:36 pablo-laptop kernel: [ 5237.111267] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:37 pablo-laptop kernel: [ 5237.241510] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:37 pablo-laptop kernel: [ 5237.241517] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:37 pablo-laptop kernel: [ 5237.371699] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:37 pablo-laptop kernel: [ 5237.371706] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:37 pablo-laptop kernel: [ 5237.501865] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:37 pablo-laptop kernel: [ 5237.501873] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:37 pablo-laptop kernel: [ 5237.502352] iwl3945 0000:06:00.0: Unable to initialize device after 5 attempts.
Mar 11 17:33:44 pablo-laptop kernel: [ 5245.165294] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:44 pablo-laptop kernel: [ 5245.165302] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.292676] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.292681] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.420165] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.420171] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.547518] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.547523] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.675049] iwl3945 0000:06:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xffffffff, s/b 0xf802020
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.675054] iwl3945 0000:06:00.0: Unable to set up bootstrap uCode: -5
Mar 11 17:33:45 pablo-laptop kernel: [ 5245.675425] iwl3945 0000:06:00.0: Unable to initialize device after 5 attempts.

After upgrading the kernel to 3.5.0-25, i noticed a new module named iwlwifi, which is also present in syslog and he seems to have a dialog with wireless card:

Mar 12 09:48:16 pablo-laptop kernel: [  209.569037] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
Mar 12 09:48:16 pablo-laptop kernel: [  209.569044] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
Mar 12 09:49:05 pablo-laptop kernel: Kernel logging (proc) stopped.

Any idea ?!

2013.03.12

Here is the output of lspci -nn | grep 0280:

06:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)

Command ls /etc/modprobe.d | grep iwl gave anything....

2013.03.13

iwlwifi was not present in /etc/modules, and was successfully added to /etc/modprobe.d/blacklist.conf.

I tried to suspend and resume for three times, but the 4th time the problem occurred.

p.s. The same problem happened with Kernel 3.2, where iwlwifi was not present.

IMPORTANT: Upgrade Manager is advising me to install 'network management framework (common files for wifi and mobile)' and 'network management framework(GNOME dialogs for wifi and mobile)'. Should I install them? What do they do exaclty? Can affect my problem ?

2013.03.14

Added the following line in file /etc/pm/config.d/config

SUSPEND_MODULES="iwl3945"

After some successfull tests, the problem occurred with new error messagges in Syslog:

iwl3945 0000:06:00.0: bad EEPROM signature,EEPROM_GP=0x00000007
iwl3945 0000:06:00.0: EEPROM not found, EEPROM_GP=0xffffffff
iwl3945 0000:06:00.0: Unable to init EEPROM
iwl3945: probe of 0000:06:00.0 failed with error -2 

Then I did another test, which was successfull, and these are the messages in syslog:

cfg80211: Calling CRDA to update world regulatory domain
cfg80211: World regulatory domain updated:
cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
iwl3945: Copyright(c) 2003-2011 Intel Corporation
iwl3945 0000:06:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
iwl3945 0000:06:00.0: Detected Intel Wireless WiFi Link 3945ABG
iwl3945 0000:06:00.0: irq 48 for MSI/MSI-X
Registered led device: phy0-led
cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
iwl3945 0000:06:00.0: loaded firmware version 15.32.2.9

2013.03.18

Problem occurred again, and I've noticed a trace called in Syslog:

Mar 18 09:39:31 pablo-laptop kernel: [18048.564008] Pid: 3535, comm: modprobe Tainted: P           O 3.5.0-25-generic #39~precise1-Ubuntu
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008] Call Trace:
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c1045c62>] warn_slowpath_common+0x72/0xa0
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f887d986>] ? _il_grab_nic_access+0x96/0xa0 [iwlegacy]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f887d986>] ? _il_grab_nic_access+0x96/0xa0 [iwlegacy]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c1045d33>] warn_slowpath_fmt+0x33/0x40
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f887d986>] _il_grab_nic_access+0x96/0xa0 [iwlegacy]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f887dac2>] il_wr_prph+0x32/0x90 [iwlegacy]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f887dc79>] il_apm_init+0x159/0x1d0 [iwlegacy]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f88c44b5>] il3945_apm_init+0x15/0x130 [iwl3945]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f887f085>] il_eeprom_init+0x45/0x1b0 [iwlegacy]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c12f2daa>] ? pci_bus_write_config_byte+0x5a/0x70
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f88c2e9d>] il3945_pci_probe+0x19d/0x4b0 [iwl3945]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13bdbe5>] ? pm_runtime_enable+0x45/0x70
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c12fa4b7>] local_pci_probe+0x47/0xb0
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c12fba08>] pci_device_probe+0x68/0x90
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c11b3077>] ? sysfs_create_link+0x17/0x20
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b5201>] really_probe+0x51/0x1c0
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13bf099>] ? pm_runtime_barrier+0x49/0xb0
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b54aa>] driver_probe_device+0x3a/0x60
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b5561>] __driver_attach+0x91/0xa0
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b54d0>] ? driver_probe_device+0x60/0x60
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b3c12>] bus_for_each_dev+0x42/0x70
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b4ee1>] driver_attach+0x21/0x30
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b54d0>] ? driver_probe_device+0x60/0x60
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b4b47>] bus_add_driver+0x187/0x260
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c12fba30>] ? pci_device_probe+0x90/0x90
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c13b5a16>] driver_register+0x66/0x110
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c12fb7d2>] __pci_register_driver+0x42/0xa0
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f8853050>] il3945_init+0x50/0x1000 [iwl3945]
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c103b80f>] ? set_memory_nx+0x5f/0x70
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c1003034>] do_one_initcall+0x34/0x170
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<f8853000>] ? 0xf8852fff
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c10a544d>] sys_init_module+0xad/0x210
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c11519d3>] ? sys_close+0x73/0xc0
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008]  [<c15ea8df>] sysenter_do_call+0x12/0x28
Mar 18 09:39:31 pablo-laptop kernel: [18048.564008] ---[ end trace f7ec9f13abaf4b1b ]---
Mar 18 09:39:31 pablo-laptop kernel: [18048.692242] iwl3945 0000:06:00.0: bad EEPROM signature,EEPROM_GP=0x00000007
Mar 18 09:39:31 pablo-laptop kernel: [18048.692249] iwl3945 0000:06:00.0: EEPROM not found, EEPROM_GP=0xffffffff
Mar 18 09:39:31 pablo-laptop kernel: [18048.692283] iwl3945 0000:06:00.0: Unable to init EEPROM
Mar 18 09:39:31 pablo-laptop kernel: [18048.692467] iwl3945: probe of 0000:06:00.0 failed with error -2
share|improve this question
    
Please edit your question to add: lspci -nn | grep 0280 Also: ls /etc/modprobe.d | grep iwl –  chili555 Mar 12 '13 at 14:20
    
Did it, as I wrote ls /etc/modprobe.d | grep iwl gave no results. –  Paolo Pemba Chialastri Mar 12 '13 at 18:56
    
2013.03.13: SORRY TO INFORM YOU THAT THE PROBLEM STILL PERSISTS. –  Paolo Pemba Chialastri Mar 13 '13 at 11:22
    
Did you ever find a solution to this? I'm having the same issue. –  balupton Mar 31 at 14:09

4 Answers 4

up vote 0 down vote accepted

UPDATE: After updating to Ubuntu 14.04 the problem disappeared. Maybe something change in the module, or the module has changed. Maybe it's important that someone have a look at that, as the 12.04 LTS is supported till 2017.

share|improve this answer
    
I'm having exactly this problem on 14.04, BOTH with wired and wireless networking. –  Victor Sergienko Jul 11 at 9:02

until this bug is fixed what I use best is this:

sudo service network-manager restart

type it in terminal after suspension

I still haven't tried it enough times to be sure that it would work everytime but I hope it does

share|improve this answer

Here is a technique that sometimes works:

gksudo gedit /etc/pm/config.d/config

Add a single line:

SUSPEND_MODULES="iwl3945"

Proofread, save and close gedit. Reboot, suspend and let us have your report.

share|improve this answer
    
Since now I've tested many times in different situations, like suspend leaving some programs running and not, or suspend and immediately remume, or resume after hours. All tests went ok, I'll let you know something more precise during next days ! –  Paolo Pemba Chialastri Mar 14 '13 at 21:14
    
Great news. I look forward to your success! –  chili555 Mar 14 '13 at 22:35
    
Sorry to inform you that the problem occurred again. I edited the main answer with syslog messages (when it works and when it don't) –  Paolo Pemba Chialastri Mar 15 '13 at 12:29
    
I have Googled this extensively: EEPROM not found, EEPROM_GP=0xffffffff and, so far, I have found no solution. Sorry. –  chili555 Mar 19 '13 at 15:39
    
Thank you chili. I also did that research over the net, finding anything interesting. Anyway, I can say the problem is solved now as 99% of the times NOW suspension works fine, after I added SUSPEND_MODULES="iwl3945" to /etc/pm/config.d/config file ! –  Paolo Pemba Chialastri Mar 21 '13 at 7:48

The driver iwl3945 is correct for your device; iwlwifi is not. Let's see why it's loading and stop it. Please do:

gksudo gedit /etc/modules

If iwlwifi is in there, remove it. Proofread, save and close gedit. Now do:

sudo su
echo "blacklist iwlwifi" >> /etc/modprobe.d/blacklist.conf
exit

Now reboot and tell us how it's working.

share|improve this answer
    
SORRY TO INFORM YOU THAT THE PROBLEM STILL PERSISTS. –  Paolo Pemba Chialastri Mar 13 '13 at 12:41
    
Since now, anyway, most of the times IT WORKS ! But I don't know why and how to reproduce the problem. Are there any kind of tests I may do when problem occurs ? –  Paolo Pemba Chialastri Mar 13 '13 at 15:04
    
The problem that it doesn't resume from suspend or that dmesg throws lots of errors? –  chili555 Mar 13 '13 at 15:27
    
The problem (now) is that most of the times works, but sometimes not. When it does not work, I find a lot of errors in Syslog (as I reported first) –  Paolo Pemba Chialastri Mar 13 '13 at 18:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.