Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

FINAL UPDATE: Here is the best solution that I found after going through this problem lots of times. The question below is outdated because as it turns out the computer is not the problem; the monitor is the problem.

I've just set up a new nettop computer (Acer Aspire Revo 3700: CPU:Atom D525, GPU:Nvidia ION2). I've just made a clean install of Ubuntu 10.10 using the standard USB pendrive method. Almost everything works OK, but the graphics are not OK: the recommended Nvidia driver is activated but the monitor is not detected, so the resolution is wrong.

How can I make Ubuntu detect my monitor?
How can I get the proper resolution (1280x1024) in Ubuntu?

I know that my monitor is not a CRT but an LCD: it's a BenQ, model T905, with 1280x1024 resolution at 60Hz, connected via a normal VGA cable. DVI or HDMI is not an option.

When I go to System>Prefs>Monitors, I get:

It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?
YES NO

If I say NO then I get a window:
enter image description here
or for YES I get this:
enter image description here

In both cases I don't see that I can fix this problem. The main reason for getting this new computer was that I was sick of having graphics problems on the old one with a very ugly solution that didn't give me hardware support - but at least I got the resultion. Why is this so difficult... sigh!

share|improve this question
    
Hah, turns out the computer is not really at fault. The problem is that my monitor isn't supplying good information to the computer. –  Torben Gundtofte-Bruun Feb 17 '11 at 18:28

3 Answers 3

up vote 2 down vote accepted

It's an EDID issue. Your monitor is trying to tell your graphics card which modes is supports (at various refresh rates) but one side of the conversation is failing.

The fix is fairly simple, you just manually tell the driver what modes you can work at. In this case it seems you can just set the refresh rates and it'll figure out the rest.

http://superuser.com/questions/60290/cant-set-1280x1024-on-ubuntu-with-nvidia-geforce-8400-gs


You might also have more luck with a digital cable going from your Revo's HDMI port to your monitors DVI-D port. You can buy conversion cables or add-on dongles that change one end of a HDMI or DVI cable. Both options are quite cheap. You can get a 2m DVI-D=>HDMI for about £6.


On a sidenote, you only ever want to use nvidia-settings. The closed nvidia drivers aren't compatible with the randr extensions... But that's not too bad as nvidia-settings isn't that bad.

share|improve this answer
    
Fixing the HorizSync and VertRefresh as described in the link solved the problem! I didn't have to replace the cable. Hooray! –  Torben Gundtofte-Bruun Feb 17 '11 at 5:47

I am fighting with a similar problem. I think there's something wrong with the Ubuntu Kernel, the version of X... something...

http://ubuntuforums.org/showthread.php?p=10461651#post10461651

share|improve this answer

Okay, open your terminal. Copy/paste each "line" one at a time and press enter after each:

sudo wget https://launchpad.net/%7Eubuntu-x-swat/+archive/x-updates/+sourcepub/1809714/+listing-archive-extra

sudo wget https://launchpad.net/%7Eubuntu-x-swat/+archive/x-updates/+packages

sudo wget ftp://download.nvidia.com/XFree86/

sudo nvidia-xconfig

Now go System > Administration > NVIDIA X Server Settings (open it)

Next select X Server Display Configuration and select your resolution

Then click 'Save to X Configuration File'

Fill in the your admin password to save the file and restart your computer for good measure. If this doesn't work then someone else will adapt my instructions to your needs.

PyroSamurai :)


Alternately, you can use this site's instructions, which are probably more credible than mine:

http://www.linoob.com/2011/04/installing-hardware-drivers-in-ubuntu/


These directions might not work for any issues you or anyone reading this might have. I personally did this and went to my monitor's preferences and selected now then selected the resolution I wanted and saved it there. My answer my not be specifically the right solution to your problem (although I hope it is), but it should be for someone who reads this post looking for a solution to a similar problem. In any case, I wrote this with the best of intentions. Hope it helps someone. ~edited for the second time on 2/29/2012, original post ended with "PyroSamurai :)".

~PyroSamurai

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.