Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I try to install bumblebee with following command:

sudo apt-get install bumblebee bumblebee-nvidia

I face with following output end with double error

Need to get 0 B/60.7 kB of archives.
After this operation, 240 kB of additional disk space will be used.
Selecting previously unselected package bumblebee.
(Reading database ... 417120 files and directories currently installed.)
Unpacking bumblebee (from .../bumblebee_3.1-1~quantalppa1_amd64.deb) ...
Selecting previously unselected package bumblebee-nvidia.
Unpacking bumblebee-nvidia (from .../bumblebee-nvidia_3.1-1~quantalppa1_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up bumblebee (3.1-1~quantalppa1) ...
Adding members from group(s) 'adm sudo admin' to 'bumblebee':
erogol
Adding user erogol to group bumblebee
update-initramfs: deferring update (trigger activated)
FATAL: Module bbswitch not found.
invoke-rc.d: initscript bumblebeed, action "start" failed.
dpkg: error processing bumblebee (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of bumblebee-nvidia:
 bumblebee-nvidia depends on bumblebee (= 3.1-1~quantalppa1); however:
  Package bumblebee is not configured yet.

dpkg: error processing bumblebee-nvidia (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Processing triggers for ureadahead ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-24-generic
Errors were encountered while processing:
 bumblebee
 bumblebee-nvidia
E: Sub-process /usr/bin/dpkg returned an error code (1)

I could not find out the reason. Is there any suggestion for the error?

share|improve this question
    
Try manually running dpkg --configure bumblebee. Paste the output either in a code block or in a linked web paste from e.g. Pastebin. –  strugee Mar 12 '13 at 0:17
    
I did not work and here is the output paste.ubuntu.com/5609119 –  Erogol Mar 12 '13 at 22:23
add comment

1 Answer 1

Try following the instructions in the top answer in this question. To summarize:

Do

sudo apt-get update
sudo apt-get install bbswitch-dkms

then if that doesn't work,

sudo apt-get update
sudo apt-get install linux-headers
sudo apt-get dist-upgrade

and then finally if even that doesn't work, install the headers for your specific kernel version:

sudo apt-get install linux-headers-$(uname -r)

Let me know if this works.

share|improve this answer
    
Sorry but does not work. I did what have you written but when I try t install bumblebee it cannot complete the installation and it just freezing. –  Erogol Mar 13 '13 at 22:07
    
Does it give an error? –  strugee Mar 16 '13 at 9:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.