Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 32-bit Ubuntu 12.10. Software Center fails to install Goldendict because of some package dependencies.

The error message looks like this:

The following packages have unmet dependencies:

goldendict: Depends: libc6 (>= 2.7) but 2.15-0ubuntu20 is to be installed
            Depends: libgcc1 (>= 1:4.1.1) but 1:4.7.2-2ubuntu1 is to be installed
            Depends: libphonon4 (>= 4:4.3.0) but it is not going to be installed
            Depends: libqt4-network (>= 4:4.5.3) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
            Depends: libqt4-xml (>= 4:4.5.3) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
            Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
            Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.3+dfsg-0ubuntu3.1 is to be installed
            Depends: libqtwebkit4 (>= 2.2~2011week36) but 2.2.1-4ubuntu1 is to be installed
            Depends: libstdc++6 (>= 4.6) but 4.7.2-2ubuntu1 is to be installed
            Depends: libvorbisfile3 (>= 1.1.2) but 1.3.2-1.3 is to be installed
            Depends: phonon but it is not going to be installed
            Depends: zlib1g (>= 1:1.2.0) but 1:1.2.7.dfsg-13 is to be installed

the output for lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:    12.10
Codename:   quantal

the output for cat /etc/apt/sources.list

arsen@arsen-VGN-NS325J:~$ cat /etc/apt/sources.list deb http://archive.ubuntu.com/ubuntu quantal multiverse universe

Any suggestions would be more than appreciated. Thank you in advance.

share|improve this question
    
Try adding the name of the packages "not to be installed" in your apt-get install command. –  carnendil Mar 11 '13 at 23:46
    
It doesn't look like you are on Ubuntu 12.04, which has most of the libqt4 stuff preinstalled. Can you add the outputs of lsb_release -a and cat /etc/apt/sources.list to the question. –  mikewhatever Mar 12 '13 at 0:04
    
@mikewhatever Thanks for noticing it, I'm using 12.10. I've added the outputs of lsb_release -a and cat /etc/apt/sources.list to the question –  arsen Mar 12 '13 at 8:14
    
Can you post the complete output of the second command. There should be more the just one line. –  mikewhatever Mar 13 '13 at 13:43
add comment

2 Answers 2

Best thing to do is just type in terminal

sudo apt-get install goldendict

It will ask you if you want to install unauthenticated dependencies. Just type y and hit enter.

share|improve this answer
    
Doesn't ask me to install anything unauthenticated. –  mikewhatever Mar 12 '13 at 1:34
add comment
up vote 0 down vote accepted

The problem was solved after I enabled the system to receive "Important security updates" and "Recommended updates" (from Software Sources, the tab "Updates")

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.