Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried many things trying to install Google earth, but none have worked. Here is one that I have tried, along with the 32 and the 64 bit versions on Googles website. here is what I put into the terminal.:

peter@ubuntu:~$ sudo apt-get install lsb-core
[sudo] password for peter: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lsb-core : Depends: alien (>= 8.36) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
peter@ubuntu:~$ sudo apt-get install lsb-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lsb-core : Depends: alien (>= 8.36) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
peter@ubuntu:~$ make-googleearth-package
The program 'make-googleearth-package' is currently not installed. You can install it by typing:
sudo apt-get install googleearth-package
peter@ubuntu:~$ make-googleearth-package--force
make-googleearth-package--force: command not found
peter@ubuntu:~$ sudo apt-get remove google-earth-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package google-earth-stable
peter@ubuntu:~$ wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add 
gpg: can't open `': No such file or directory

peter@ubuntu:~$ 
peter@ubuntu:~$ sudo sh -c 'echo "deb http://dl.google.com/linux/earth/deb/ stable main" >> /etc/apt/sources.list.d/google.list'
peter@ubuntu:~$ 
peter@ubuntu:~$ sudo apt-get update
Ign http://security.ubuntu.com precise-security InRelease
Ign http://archive.ubuntu.com precise InRelease                                
Hit http://security.ubuntu.com precise-security Release.gpg                    
Ign http://archive.canonical.com quantal InRelease                             
Get:1 http://repository.spotify.com stable InRelease [2,979 B]                 
Ign http://archive.ubuntu.com precise-updates InRelease                        
Ign http://ppa.launchpad.net quantal InRelease                                 
Hit http://security.ubuntu.com precise-security Release                        
Hit http://archive.canonical.com quantal Release.gpg                           
Ign http://archive.ubuntu.com precise-proposed InRelease                       
Hit http://ppa.launchpad.net quantal Release.gpg                               
Hit http://security.ubuntu.com precise-security/main Sources                   
Hit http://repository.spotify.com stable/non-free Sources                      
Hit http://archive.canonical.com quantal Release                               
Ign http://archive.ubuntu.com precise-backports InRelease                      
Hit http://ppa.launchpad.net quantal Release                                   
Hit http://security.ubuntu.com precise-security/restricted Sources             
Hit http://repository.spotify.com stable/non-free amd64 Packages               
Hit http://archive.canonical.com quantal/partner amd64 Packages                
Hit http://archive.ubuntu.com precise Release.gpg                              
Hit http://ppa.launchpad.net quantal/main Sources                              
Hit http://security.ubuntu.com precise-security/universe Sources               
Get:2 http://archive.ubuntu.com precise-updates Release.gpg [198 B]            
Hit http://ppa.launchpad.net quantal/main amd64 Packages                       
Hit http://security.ubuntu.com precise-security/multiverse Sources             
Get:3 http://archive.ubuntu.com precise-proposed Release.gpg [198 B]           
Hit http://security.ubuntu.com precise-security/main amd64 Packages            
Hit http://archive.ubuntu.com precise-backports Release.gpg                    
Hit http://security.ubuntu.com precise-security/restricted amd64 Packages      
Hit http://archive.ubuntu.com precise Release                                  
Hit http://security.ubuntu.com precise-security/universe amd64 Packages        
Ign https://private-ppa.launchpad.net quantal InRelease                        
Get:4 http://archive.ubuntu.com precise-updates Release [49.6 kB]              
Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages      
Hit http://security.ubuntu.com precise-security/main Translation-en            
Get:5 http://archive.ubuntu.com precise-proposed Release [49.6 kB]             
Hit http://security.ubuntu.com precise-security/multiverse Translation-en      
Hit https://private-ppa.launchpad.net quantal Release.gpg                      
Ign http://repository.spotify.com stable/non-free Translation-en_US            
Ign http://archive.canonical.com quantal/partner Translation-en_US             
Hit http://archive.ubuntu.com precise-backports Release                        
Hit https://private-ppa.launchpad.net quantal Release                          
Ign http://ppa.launchpad.net quantal/main Translation-en_US                    
Ign http://archive.canonical.com quantal/partner Translation-en                
Ign http://repository.spotify.com stable/non-free Translation-en               
Hit http://archive.ubuntu.com precise/main Sources                             
Ign http://ppa.launchpad.net quantal/main Translation-en                       
Hit https://private-ppa.launchpad.net quantal/main amd64 Packages             
Hit http://archive.ubuntu.com precise/restricted Sources                      
Hit http://security.ubuntu.com precise-security/restricted Translation-en     
Hit http://archive.ubuntu.com precise/universe Sources  
Hit http://archive.ubuntu.com precise/multiverse Sources
Hit http://security.ubuntu.com precise-security/universe Translation-en
Hit http://archive.ubuntu.com precise/main amd64 Packages
Hit http://archive.ubuntu.com precise/restricted amd64 Packages
Hit http://archive.ubuntu.com precise/universe amd64 Packages
Hit http://archive.ubuntu.com precise/multiverse amd64 Packages
Hit http://archive.ubuntu.com precise/main Translation-en
Hit http://archive.ubuntu.com precise/multiverse Translation-en
Hit http://archive.ubuntu.com precise/restricted Translation-en
Ign http://security.ubuntu.com precise-security/main Translation-en_US
Hit http://archive.ubuntu.com precise/universe Translation-en
Ign http://security.ubuntu.com precise-security/multiverse Translation-en_US
Get:6 http://archive.ubuntu.com precise-updates/main Sources [370 kB]
Ign http://security.ubuntu.com precise-security/restricted Translation-en_US   
Ign http://security.ubuntu.com precise-security/universe Translation-en_US     
Ign http://dl.google.com stable InRelease                                      
Ign http://dl.google.com stable InRelease                                      
Hit http://dl.google.com stable Release.gpg                                    
Get:7 http://dl.google.com stable Release.gpg [198 B]                          
Hit http://dl.google.com stable Release                                        
Get:8 http://dl.google.com stable Release [1,338 B]                            
Hit http://dl.google.com stable/main amd64 Packages                            
Get:9 http://dl.google.com stable/main amd64 Packages [469 B]                  
Get:10 http://archive.ubuntu.com precise-updates/restricted Sources [5,120 B]  
Get:11 http://archive.ubuntu.com precise-updates/universe Sources [80.2 kB]    
Ign http://dl.google.com stable/main Translation-en_US                         
Ign http://dl.google.com stable/main Translation-en                            
Ign http://dl.google.com stable/main Translation-en_US                         
Ign http://dl.google.com stable/main Translation-en                            
Get:12 http://archive.ubuntu.com precise-updates/multiverse Sources [4,729 B]  
Get:13 http://archive.ubuntu.com precise-updates/main amd64 Packages [585 kB]  
Ign https://private-ppa.launchpad.net quantal/main Translation-en_US           
Ign https://private-ppa.launchpad.net quantal/main Translation-en              
Get:14 http://archive.ubuntu.com precise-updates/restricted amd64 Packages [9,579 B]
Get:15 http://archive.ubuntu.com precise-updates/universe amd64 Packages [185 kB]
Get:16 http://archive.ubuntu.com precise-updates/multiverse amd64 Packages [9,436 B]
Get:17 http://archive.ubuntu.com precise-updates/main Translation-en [261 kB]  
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en        
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en        
Get:18 http://archive.ubuntu.com precise-updates/universe Translation-en [109 kB]
Get:19 http://archive.ubuntu.com precise-proposed/restricted amd64 Packages [2,093 B]
Get:20 http://archive.ubuntu.com precise-proposed/main amd64 Packages [47.6 kB]
Get:21 http://archive.ubuntu.com precise-proposed/multiverse amd64 Packages [1,442 B]
Get:22 http://archive.ubuntu.com precise-proposed/universe amd64 Packages [16.8 kB]
Get:23 http://archive.ubuntu.com precise-proposed/main Translation-en [26.9 kB]
Hit http://archive.ubuntu.com precise-proposed/multiverse Translation-en       
Hit http://archive.ubuntu.com precise-proposed/restricted Translation-en       
Get:24 http://archive.ubuntu.com precise-proposed/universe Translation-en [10.1 kB]
Hit http://archive.ubuntu.com precise-backports/restricted amd64 Packages      
Hit http://archive.ubuntu.com precise-backports/main amd64 Packages            
Hit http://archive.ubuntu.com precise-backports/multiverse amd64 Packages      
Hit http://archive.ubuntu.com precise-backports/universe amd64 Packages        
Hit http://archive.ubuntu.com precise-backports/main Translation-en            
Hit http://archive.ubuntu.com precise-backports/multiverse Translation-en      
Hit http://archive.ubuntu.com precise-backports/restricted Translation-en      
Hit http://archive.ubuntu.com precise-backports/universe Translation-en        
Ign http://archive.ubuntu.com precise/main Translation-en_US                   
Ign http://archive.ubuntu.com precise/multiverse Translation-en_US
Ign http://archive.ubuntu.com precise/restricted Translation-en_US
Ign http://archive.ubuntu.com precise/universe Translation-en_US
Ign http://archive.ubuntu.com precise-updates/main Translation-en_US
Ign http://archive.ubuntu.com precise-updates/multiverse Translation-en_US
Ign http://archive.ubuntu.com precise-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com precise-updates/universe Translation-en_US
Ign http://archive.ubuntu.com precise-proposed/main Translation-en_US
Ign http://archive.ubuntu.com precise-proposed/multiverse Translation-en_US
Ign http://archive.ubuntu.com precise-proposed/restricted Translation-en_US
Ign http://archive.ubuntu.com precise-proposed/universe Translation-en_US
Ign http://archive.ubuntu.com precise-backports/main Translation-en_US
Ign http://archive.ubuntu.com precise-backports/multiverse Translation-en_US
Ign http://archive.ubuntu.com precise-backports/restricted Translation-en_US
Ign http://archive.ubuntu.com precise-backports/universe Translation-en_US
Fetched 1,828 kB in 27s (66.3 kB/s)
Reading package lists... Done
peter@ubuntu:~$ 
peter@ubuntu:~$ sudo apt-get install google-earth-stable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 google-earth-stable : Depends: lsb-core (>= 3.2) but it is not going to be installed
                       Depends: ia32-libs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
peter@ubuntu:~$ 
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.