Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

For whatever reason, aptitude is stuck on upgrading libboo2.0.9-cil. I tried dpkg --configure -a and restarting the upgrade, but that doesn't seem to do anything. It just sits there on

nyxtom@ubuntu$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  google-chrome-unstable libboo2.0.9-cil
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 21.8MB of archives.
After this operation, 1,606kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 stable/main google-chrome-unstable 6.0.495.0-r56152 [21.2MB]
Get:2 lucid/universe libboo2.0.9-cil [546kB]
Fetched 21.8MB in 1min 6s (325kB/s)                                                                
(Reading database ... 
dpkg: warning: files list file for package `libboo2.0.9-cil' missing, assuming package has no files currently installed.
(Reading database ... 168942 files and directories currently installed.)
Preparing to replace libboo2.0.9-cil (using .../libboo2.0.9-cil_0.9.2.3383+dfsg-1_all.deb) ...
Unpacking replacement libboo2.0.9-cil ...
share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 17:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

@nyxtom: How active is the hard disk when apt-get upgrade hangs? If you run tail -f /var/log/kern.log in another terminal, does anything appear after you start the upgrade? – Gilles Aug 19 '10 at 20:08
Also, the output from dpkg --debug=313 -i /var/cache/apt/archives/libboo2.0.9-cil_0.9.2.3383+dfsg-1_all.deb may help. – Gilles Aug 19 '10 at 20:12
Everything seems to be working from the hard drive's perspective. dpkg --debug=313 -i /var/cache/apt/archives/libboo2.0.9-cil_0.9.2.3383+dfsg-1_all.deb however shows that the status database area is locked by another process. – nyxtom Aug 19 '10 at 20:37
Well, of course it will be locked if I'm running what I ran above. Nevertheless... it doesn't seem to want to unpackage libboo – nyxtom Aug 19 '10 at 20:39
Oh duh, let me download and run that in debug mode... didn't notice that until now. – nyxtom Aug 19 '10 at 20:41

2 Answers 2

Ran apt-get install on boo instead, then was able to simply upgrade chrome unstable. However, for getting rid of my other issue (where dpkg was locking up). Running killall on that as well as removing the locks:


That fixed that issue as well.

share|improve this answer

Well, I notice that gives a 404 Not Found error.

Maybe the issue is not that there's a problem with libboo, but that apt-get is hanging on the 404 error?

Perhaps try uninstalling google-chrome-unstable (and disabling the entry in your apt configuration), completing your upgrade, and then reinstalling google-chrome?

share|improve this answer
At this point apt-get has already downloaded the chrome package. – Gilles Aug 19 '10 at 20:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.