Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu (installed Ubuntu 12.10 desktop on my Mac Mini today from Ubuntu iso – mac mini had blank SSD on it i.e. no OS X at all).

First drama is that Ubuntu installer seems to be setup for DHCP whereas my LAN is all static IP based.

Anyway, Ubuntu installed okay except that it seems to have gone into loopback mode and cannot find the Ethernet adapter on the Mac Mini.

Doing an ifconfig -a confirms the loopback.

Doing an lspci reveals the following:

01:00.0 Ethernet controller: Broadcom Corporation Netxtreme BCM57766 Gigabit Ethernet PCIe (rev 05)

I tried setting /etc/hosts file to include:

127.0.0.1 localhost
192.168.0.2 merlot

I wanted to set /etc/network/interfaces file to have:

auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
gateway 192.168.0.1

Except that eth0 doesn't seem to exist as far as Ubuntu is concerned. 192.168.0.1 is my modem/router which connects directly to the Internet.

I wanted to edit /etc/resolv.conf so that I could specify some DNS name servers (3 in total) that should be used except that the resolv.conf file contained text warning me that the file would be overwritten so don't bother doing anything manually in that file.

Checking 'System Settings > Network' I cannot see wired Ethernet at all. There is, for some reason, a 'Network Proxy' defined. A messagebox appears saying:

The system network services are not compatible with this version.

When I am able to modify via 'System Settings > Network' the only option permitted to me is to add a 'vpn' definition.

I have not been able to establish a network connection at all.

  1. What can I try to fix this?
  2. Do I need a driver from somewhere and can I install said driver without having to recompile the kernel?
  3. Is there a GUI way of setting network parameters or is editing the hosts, resolv.conf, and interfaces file the only way?
  4. How can I find the Ethernet Mac address from terminal (I couldn't get it by doing ifconfig -a)?
share|improve this question
    
It will help us propose a solution if we knew the result of this terminal command: lspci -nn | grep 0200. Is Network Manager installed and running here? If so, manual configuration may not work very well. –  chili555 Mar 11 '13 at 21:44
    
I did a standard install from an iso DVD. How do I find out if Network Manager is installed? I only tried manual configuration because I couldn't get the GUI to work properly. Here is the information requested: –  tontoOzzy Mar 11 '13 at 22:50
    
lspci -knn | grep -i eth -A 2 01:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM57766 Gigabit Ethernet PCIe [14e4:1686] (rev 01) Subsystem: Broadcom Corporation NetXtreme BCM57766 Gigabit Ethernet PCIe [14e4:1686] 01:00.1 SD Host controller [0805]: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader [14e4:16bc] (rev 01) Subsystem: Broadcom Corporation Device [14e4:0000] lspci -nn | grep 0200 01:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM57766 Gigabit Ethernet PCIe [14e4:1686] (rev 01) –  tontoOzzy Mar 11 '13 at 22:51
    
There are two lspci commands in the above string. The forum software bunched the separate paragraphs together. –  tontoOzzy Mar 11 '13 at 22:52
    
I suggest we address the driver first and then the Network Manager issue. Your relatively new device is going to be driven by the driver tg3 in kernel 3.7.xx. Ubuntu 12.10 uses 3.5.xx. The solution is to download and install the driver from Broadcom. The compile process requires many prerequisites. Do you have access to wireless? Can you temporarily borrow an ethernet card from a pal? Here are some important references we'll need as we proceed: broadcom.com/support/ethernet_nic/netxtreme_desktop.php ubuntuforums.org/… –  chili555 Mar 12 '13 at 1:10

2 Answers 2

To answer the question regarding resolv.conf...

When using ifup and /etc/network/interfaces to configure interfaces, you specify nameserver addresses on a dns-nameservers option line, as follows (using three example addresses 1.1.1.1, 2.2.2.2 and 3.3.3.3).

auto eth0
iface eth0 inet static
    address 192.168.0.2
    netmask 255.255.255.0
    gateway 192.168.0.1
    dns-nameservers 1.1.1.1 2.2.2.2 3.3.3.3
share|improve this answer

i had the same issue where I was not getting the eth0, However I managed to fix it. I hope this will help.

type

"route" or "netstat -r"

and check what routing table is coming up for you. Usually this list the interface as well.

if you don't see the "eth0" do

/etc/init.d/networking restart

as sometime main network adapter is disabled by default. (in case of centos, there is one parameter ONBOOT=No by default)

Finally edit your

/etc/network/interface

file as below if adapter is in bridged mode and restart the network manager by issuing the /etc/init.d/networking restart command.

auto lo

iface lo inet loopback

iface br0 inet static

address 192.168.2.15

netmask 255.255.255.0

gateway 192.168.2.2

bridge_ports eth0

You may have to reboot the system and issue route command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.