Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've searched for this problem but I cant find a straight answer.

If I go into /etc/class/backlight, there's nothing there. Could someone help?

I have the Nvidia Driver installed, and the Fn keys aren't changing the brightness.

share|improve this question

2 Answers 2

First give a try to obacklight.

Earlier it solved may problems with sony laptops. Most preferable solution. It is based on nvidabl. You need to install nvidiabl first. Installation instruction is available on the page.


If the above is not working, revert back all changes. Uninstall nvidiabl & remove obacklight script from /etc/init.d. Then follow below instructions:

  1. Execute gksu gedit /etc/default/grub

  2. Change this line:

    GRUB_CMLINE_LINUX_DEFAULT="quiet splash"
    

    to something like the below:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
    
  3. Execute sudo update-grub and reboot.

See if brightness keys are working.

It is still possible ubuntu won't remember your brightness settings. So you have to change brightness each time.


This is for setting the brightness manually after doing the above steps.

Try the following for the paths shown by the command ls /sys/class/backlight/*/brightness and replace accordingly. An example path will be like /sys/class/backlight/acpi_video0/brightness.

  1. For the path(s), get the maximum brightness:

    cat /sys/class/backlight/acpi_video0/max_brightness
    
  2. Try a lower value to set the brightness. Let's say if the output is 16, try half the number:

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

If this works, make this happen in each login automatically by doing the following:

  1. sudo gedit /etc/rc.local

  2. Enter this line just before exit 0. It should look like

    echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness exit 0


Another fix if the above fails:

  1. Run nVidia X Server settings which you can find in the Application menu.

  2. Select X Server Display configuration and chose the save to x configuration file option. This will build file xorg.conf. Close Nvidia X Server settings.

  3. sudo gedit /etc/X11/xorg.conf in terminal.

  4. Find this section:

    Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 540M"
    EndSection 
    

    And change it to something like this:

    Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 540M"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    
  5. Reboot.

share|improve this answer

Execute the following commands:

sudo -s    
echo n > /sys/class/backlight/acpi_video0/brightness

n is the desired brightness value. For example, if I want to set my brightness to 5, I’d run this:

sudo -s    
echo 5 > /sys/class/backlight/acpi_video0/brightness

This solution works on my Sony Vaio laptop.

Edit:

Try the answer to this question: Brightness is reset to Maximum on every Restart

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.