Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New to ubuntu here and am trying to set up 12.04 alongside my windows7 install. I got the iso onto a flash drive, managed to install everything just fine, but when I restart the computer after completing the installation, I have no boot options and windows loads automatically.

This makes me think that I installed the bootloader in the wrong place and maybe bios cant find it, but im not sure..

This is an img of my disk partitions from windows. Image

Basically Ubuntu should go to the 360gb slot on disk1, but when i tried installing the bootloader in both that partition, and also in the root of that disk, neither were recognized during start-up.

Im hesitant to try and install it over my main boot (disk 0 :core) as this is a ntfs filesystem vs the ext4 that im trying to install ubunt with.

Basically just looking for the easiest way to get things running without affecting my windows too much. Any tips/ advice?

EDIT: So Ive now tried installing the bootloader on /dev/sda (Disk 0) where my windows boot is from, Ive checked to make sure bios is booting from this disk first, and I still have no boot options to select w7/ub. Are there any ways I can diagnose this problem further?

Thanks!

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

You need to install it on the disk selected as primary boot disk in Bios: in your situation, on disk 0. This has no problem (people with only 1 disk has no other option).

If you prefer not modifying your current disk 0, you can install the bootloader on disk 1 and select disk 1 to boot from BIOS. You can after that (if the installer didn't do it already) update grub to find your windows installation and boot it from there too using the grub menu.

EDIT: How to reinstall grub2 from Live CD (or USB) obs: I think better re-installing grub as you already installed it many times I suppose and this way we are sure it is installed in the right place.

  • boot with the live USB
  • check the name of your main ubuntu system partition with sudo fdisk -l (will be /dev/sdb1 or 2 probably in your case)
  • mount it: sudo mount /dev/sdXY /mnt (obs: sdXY is what you found on previous step)
  • Reinstall grub2 with: sudo grub-install --root-directory=/mnt /dev/sdX (obs: do not include partition number in /dev/sdX, not sdXY, it is better not to install on a partition) - This should be /dev/sdb for disk1 and /dev/sda for disk 0 and it has to be the disk used by BIOS as primary boot.
  • unmount the partition: sudo umount /mnt
  • reboot (select in BIOS the disk you used to install grub as primary boot disk)

If you don't see grub menu at boot, try pressing and holding SHIFT key during boot and the menu should be displayed.

If you don't have windows option in menu, after booting in Ubuntu use sudo update-grub and reboot.

More complete documentation on grub and Ubuntu can be found at: Ubuntu Documentation - Grub2 install

share|improve this answer
    
So Ive attempted this, and still no boot options, just going straight to windows. is there some way to diagnose this? –  MSEoris Mar 11 '13 at 15:31
1  
I saw your Question Edit too. So you have installed the bootloader on disk 0 and your system boots directly to windows or ubuntu? and if you select disk 1 to boot from BIOS? If it boots in Ubuntu, you can update grub with: sudo update-grub so it will scan your system and prepare the grub menu. If it boots in Windows, I think you will need to boot with ubuntu live CD to do this. –  laurent Mar 11 '13 at 15:50
    
It boots directly to Windows regardless of disk 0 or 1. I can get to ubuntu using my liveUSB, but its only the 'trial version' which I used to install ubuntu in the first place. is it ok to try this sudo update-grub from there? –  MSEoris Mar 11 '13 at 15:55
1  
Yes but I will update my answer in a few minutes on how to do it. –  laurent Mar 11 '13 at 16:06
    
done. If you have a separate /boot partition on ubuntu (probably not the case), you need to mount it in the same way as the system one in /mnt/boot before installing grub2. –  laurent Mar 11 '13 at 16:52
show 2 more comments

Try installing the boot loader to Disk 1, or it should be /dev/sdb in Ubuntu. On boot you must enter the bios (common keys to do this are Delete, F11 or F12) and choose which disk to boot from. I do this myself with Win7 and Ubuntu installed.

share|improve this answer
add comment

If your grub loader is messed up, or you can't boot to ubuntu you can chose to repair Grub 2 or use "EasyBCD" under windows 7 and configure it to load Grub 2, this is better if you plan to ditch ubuntu later on:

  1. Repairing Grub:

  2. EasyBCD under Windows:

    • Download the non commercial edition of "EasyBCD" from: http://neosmart.net/EasyBCD/
    • Install it.
    • Once inside EasyBCD on the left panel click on "Add New Entry".
    • On the right panel click on "Linux" tab.
    • Change type to "Grub 2".
    • Click on "Add Entry".
    • On the left panel click on "BCD Deployment".
    • On the right panel select "Install the Windows Vista/7 Bootloader to the MBR" and then click on "Write MBR".
    • Reboot, now you can choose between "windows 7" and "NeoSmart Linux".
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.