Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got a new laptop (a Vaio S series) which came with Windows 8. I wanted to install Ubuntu 12.10 alongside Windows, so I used a Ubuntu CD, booted from it and installed Ubuntu. Installation finished successfully, but then the problems began:

  • After restarting, I encountered issues in terms of choosing which OS I wanted to use when starting up. The "Choosing OS" screen was a Windows one, and choosing Ubuntu worked, but choosing Windows didn't. After going through the Recovery Menu option, I was able to boot Windows, but after the next restart I could no longer boot Ubuntu and had to reinstall it at that point.
  • I googled around and found out about SecureStart and UEFI. A blog post suggested I should turn off SecureStart and disable UEFI, switching to Legacy boot instead. I did that in my BIOS and reinstalled Ubuntu. Now Ubuntu was fine, but if I tried to choose Windows on the "Choose OS" screen (which was now a Ubuntu one) I got a "file not found" error.
  • At this point I ran boot-repair. It ran to completion and on startup there were new Windows entries in the "choose OS" screen as well as the existing ones. But the new Windows entries gave me an "invalid signature error".
  • More importantly, boot-repair gave me a warning that my computer is set to Legacy and I should probably switch it UEFI. But, worryingly, I can no longer get to the BIOS Setup! On restart/startup even if I press F2 right from the start (that is the correct key), it never goes into BIOS Setup, just straight to the Ubuntu "Choose OS" screen. To be honest, I'm more worried about losing access to the BIOS Setup now than I was about losing access to Windows.

I hope this makes some sense. Boot repair gave me this at the end of its execution: http://paste.ubuntu.com/5601830

Any help you can give me will be gratefully received!

share|improve this question
    
Did you use the 64bit Ubuntu? Also take a look at This. Also try pressing the Assist button –  Mitch Mar 11 '13 at 11:18
    
Ah, Assist button. That did the trick, I was able to get to BIOS Setup now. Thank you! For the record, I gave up with dual boot and just wiped the whole thing with a clean Ubuntu installation. –  Yannis Lionis Mar 13 '13 at 2:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.