Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been running 12.10 for ~(two weeks) now and have had my fair share of trouble with it. Of course, this has thought me a great deal of lessons of using ubuntu, the command line and Linux in general. It also sparked my interests in open-source/free software and why it is so precious. I've learned to respect the community and am actively learning my way through.

Now, last night I attempted to optimize my laptop power consumption and installed, amongst others, powertop. As far as I can recall, I didn't do anything dramatic to my system, except changing the power governor from ondemand to powersave.

This morning the system goes into a flashing cursor in top left after boot. At this mode I can't enter TTY-s using ctrl-alt-F(1-7). So, I reboot -> Advanced options for... -> ...(recovery mode) -> root and attempted to play with lightdm as was done here. Initially there was a problem with the /var/lib/dpkg/lock and /var/lib/apt/lists/lock . So I removed the locks. Then tried

dpkg-reconfigure lightdm

and it worked (no error messages). Rebooted and started normally and this time even the cursor went fishing. So, no flashing, no I/O whatsoever (to a mortal).

Then, went back to recovery -> root and did some of the listed options, namely: check the file systems (fsck), update grub bootloader (grub). Tried to failsaveX and that didn't start either. So, back to root shell and

apt-get install --reinstall lightdm

I also set the power gov back to "ondemand". Also tried several other things, which are to my judgement, not worth mentioning.

So, quite desperate. Please give a pointer as to how to proceed.

SYSTEM SPECS: Ubuntu 12.10 on a DELL E6420 laptop. All worked out-of-the box with 12.10, with the occasional crash upon system update.

EDIT [1]:

cat /etc/X11/default-display-manager



When I try

sudo service lightdm start 

System goes back into black screen with no I/O option.

EDIT [2]:

After some reading and testing, the problem emerged as wireless not working. So, connected to ethernet. Then run the same commands as above (udpated lightdm) and log-in screen appeared, but could not connect. Then, went back into tty1 and re-installed compiz and unity. Then reboot and BAM - works!

As to the many existing issues with Linux, I could, with my lately gathered understandings and skills, generalize the main cause of errors in Linux is the keyboard operator (aka ME).


share|improve this question

put on hold as off-topic by Eric Carvalho, Fabby, ByteCommander, bodhi.zazen, waltinator yesterday

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This question is specific to an end of life Ubuntu release. These are no longer supported and are therefore off-topic here. To upgrade, see: How to install software or upgrade from old unsupported release?" – bodhi.zazen, waltinator
  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Fabby, ByteCommander
If this question can be reworded to fit the rules in the help center, please edit the question.

12.10 is beyond end of life. Upgrade to a supported release. Probably easiest to back up your data and do a fresh install. –  bodhi.zazen 2 days ago