Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have used Mythbuntu, Ubuntu 12.10 32-bit OS, and they have all worked properly with the wifi driver which is apparently the Broadcom 4312. Then I deleted the Linux partitions, rebooted with Ubuntu 12.10 64-bit because that was the only 64-bit version I could find. I did it through USB boot, installed alongside my Windows 7.

I noticed before installing that it couldn't detect wifi connections so I used ethernet. It installed as quickly as the 32-bit version of 12.10. I finally got to the desktop environment after rebooting, and I noticed that I still couldn't connect to my wireless internet. I've browsed for hours and hours to get it working, but I still have found no answer. I hope someone can help give me a working yet simple solution. If not then I guess lay it down on me the hard way.

share|improve this question
    
Have you tried this ? askubuntu.com/q/55868/35775 –  Web-E Mar 10 '13 at 5:30
    
yeah but i havent been able to use any of those,they all seemed valuable but broken links and/or not the right thing,im scared because its been a problem for several years and still unfixed –  warren Mar 10 '13 at 16:27
    
What is the exact identity of your Broadcom? Run this terminal command and pick out the Broadcom wireless. Edit your question to add all the details: lspci -nn –  chili555 Mar 10 '13 at 16:34
    
it says Broacom Corporation BCM4312 802.11b/g LP-PHY –  warren Mar 10 '13 at 16:41
    
I think it says more than that. The 'more' is what I need to see: 14e4:???? –  chili555 Mar 10 '13 at 16:45

1 Answer 1

Your device, 14e4:4315 uses the Broadcom STA driver. Please get a temporary wired ethernet connection and do:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

Assuming the wireless switch is on, your wireless should now be working; check:

rfkill list all
share|improve this answer
    
E: Unable to locate package bcmwl E: Package 'kernel-source' has no installation candidate warren@warren-Inspiron-1545:~$ sudo modprobe wl FATAL: Module wl not found. warren@warren-Inspiron-1545:~$ –  warren Mar 10 '13 at 17:49
    
Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed. ERROR: Module b43 does not exist in /proc/modules ERROR: Module b43legacy does not exist in /proc/modules ERROR: Module ssb does not exist in /proc/modules ERROR: Module bcm43xx does not exist in /proc/modules ERROR: Module brcm80211 does not exist in /proc/modules ERROR: Module brcmfmac does not exist in /proc/modules ERROR: Module brcmsmac does not exist in /proc/modules ERROR: Module bcma does not exist in /proc/modules FATAL: Module wl not found. update-initramfs –  warren Mar 10 '13 at 18:10
    
'kernel source missing' indicates that linux-headers was not installed or installed incorrectly. Please try again: sudo apt-get install linux-headers-generic and then do sudo apt-get install linux-headers-$(uname -r) and then try again: sudo apt-get install --reinstall bcmwl-kernel-source ; sudo modprobe wl –  chili555 Mar 10 '13 at 18:15
    
It looks like you typed bcmwl kernel-source; it is actually bcmwl-kernel-source. –  chili555 Mar 10 '13 at 18:17
    
Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed. ERROR: Module b43 does not exist in /proc/modules ERROR: Module b43legacy does not exist in /proc/modules ERROR: Module ssb does not exist in /proc/modules ERROR: Module bcm43xx does not exist in /proc/modules ERROR: Module brcm80211 does not exist in /proc/modules ERROR: Module brcmfmac does not exist in /proc/modules ERROR: Module brcmsmac does not exist in /proc/modules ERROR: Module bcma does not exist in /proc/modules FATAL: Module wl not found. very aggravating –  warren Mar 10 '13 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.