Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a computer that has no monitor attached to it.

When I boot the system, X fails to start because there is no monitor detected. If I boot it with a monitor attached and after X has started, when I remove the monitor everything works fine.

Details and Background:

This computer is a kind of hardware consolidation server. It's only purpose is to run two Virtual Box VM's that run Windows XP and some important but seldom used (once or twice a month) programs. For a couple of time it has been lying in a corner with an old monitor attached to it and working great.

But space in the office was getting scarce and I moved the computer to the server room. There is no monitor attached to it there (no space), and sometimes the computer is rebooted. When it boots without monitor X is not started, the vms doesn't start and I get called to solve the problem.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

According to this tread a possible solution for 10.04 may be to both

  • define a standard xorg.conf, and
  • prevent KMS at boot.

However solution #13 there with resistors plugged to the vga port for fake monitor is really funky.

share|improve this answer
2  
OMG... I have a couple of spare DVI-VGA adapters and some resistors here... and the computer video card has both VGA and DVI port. Something inside my loves to try that solution ;). –  Javier Rivera Feb 16 '11 at 11:43
    
+1 for solution #13 –  djeikyb Feb 16 '11 at 11:44
1  
Ok, this solves the problem. No, not #13, the boring way: custom xorg.conf and disabling KMS. This is the xorg.conf that I used: pastebin.com/y8tRZpJa , it's the same as #21 in the forum post, but using the radeon driver instead of vesa. –  Javier Rivera Feb 16 '11 at 13:57

I think it's because Xorg nowdays are designed to run without a config file, that is: some kind of auto-detection. For sure, it has the "problem" that it cannot detect your monitor if it's not there ... What I would do is to create a config file for Xorg server, so you have "hard coded" config then, no need for auto detection.

Run this command from a text VT as root:

sudo Xorg -configure

It will create a config file for you, if I remember well with name something like xorg.conf.new in your home directory. Move/copy it as /etc/X11/xorg.conf, also you may need to customize it a bit. If X works properly with that configuration (try that with a monitor attached first, of course), you can try it out what happens if you remove the monitor.

share|improve this answer
    
I'll try this as soon as possible and keep you updated. –  Javier Rivera Feb 16 '11 at 11:41
    
Ah, and the other answer you got here is important: KMS can be a problem, I haven't mentioned it, since I don't use KMS, I have only machines with nvidia cards where I use nvidia's driver ... –  LGB Feb 16 '11 at 12:55
    
Didn't work. Xorg -configure just hang the computer. It's using the radeon driver. –  Javier Rivera Feb 16 '11 at 13:22
    
It shouldn't hang ... What way did it hang exactly? Maybe you can also check the xorg log file out in /var/log to see what happened. –  LGB Feb 17 '11 at 8:44

Check out IgnoreEDID.

Option "IgnoreEDID" "TRUE"
share|improve this answer
1  
Where in the Xorg config should this be placed? –  gertvdijk Jul 22 '13 at 11:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.