Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a confusing issue with my SSD. I will describe some of the symptoms.

  • Randomly the GUI will crash. The launcher and panel disappear, programs won't launch and eventually everything blanks out.
  • I can switch to another TTY, but when I try to log in I get the message

    I/O error, dev sda, sector [some sector number]

  • I then have to force reboot my machine at which point the BIOS fails to recognize my disk and leaves me at a blank command prompt.
  • The first time this happened, I thought my drive was dead, but it turns out if I just shut down my machine and start it back up, the drive appears again and I can boot into Ubuntu.
It seems like everything points to a failing drive. BUT besides this issue I can't find any evidence of this.

  • All the SMART tests are positive.
  • I've run e2fsck on both partitions and it seemed to be fine.
  • I rad badblocks to check for bad sectors and nothing was found.
  • I've checked dmesg after an incident and nothing jumps out.
  • Most importantly, this issue is reproducible. As long as I force shut down, then bring the machine back up, everything is fine for an hour or so. If I reset the machine, the BIOS can't load the drive. I've done this probably 10 times now and the results are always the same.

I just don't know what else to check now. I'm fine with getting a new drive if I need to, but since I can't actually prove that it's broken, I don't want to replace it unnecessarily.

Basically, can anyone recommend any other tests or debugging steps to prove one way or another the state of my disk?

At Tom Brossman's suggestion, I tried switching the SATA port used by the drive. This had no effect. I also changed SATA cables which didn't work either.

Here's the output of e2fsck.

Here's the output of `badblocks -v'

Drive information Drive information

SMART status SMART status

share|improve this question
    
I had a vaguely similar issue that turned out to be a flaky SATA controller, and I plugged the drive into a different port as a workaround. Are you able to try this? If it's a laptop you might not... –  Tom Brossman Mar 10 '13 at 1:12
    
I have a similar issue (corrupted and then lost files every 1-2 weeks) and then I switch the ssd of my 2 laptops (put the ssd A in the laptop B and the ssd B in the laptop A). I think it was an incompatibility issue with Intel ssd and the American Megatrends motherboard. –  desgua Mar 10 '13 at 2:03
    
@TomBrossman I just switched the SATA cable to a different port. I will let you know the results. Thanks for the suggestion. –  Kris Harper Mar 11 '13 at 1:56
    
@TomBrossman I've had the same issue using both a different SATA port and a different SATA cable. I don't suppose you have any other ideas? –  Kris Harper Mar 12 '13 at 1:12
    
At this point I would just contact the manufacturer of the drive and tell them the drive is defective, and that I want to exchange it. Be ready for them to ask you to run some Windows-only diagnostic tool. Unless this is spelled out in your warranty T&C's you have no obligation to help them troubleshoot their failing product. –  Tom Brossman Mar 12 '13 at 18:09

4 Answers 4

I have the same problem with my Dell Latutide E6530 and ADATA SSD SX900 512GB. It looks like a problem with disk controller and the cache.

I found some workaround. Even if cache is on I enable it again by:

sudo hdparm -W1 /dev/sda

Very seldom (do not ask me why) it do not work so in this case I disable cache:

sudo hdparm -W0 /dev/sda

Did you check it out with any Windows? It should answer if it is hardware of software problem.

share|improve this answer
up vote 1 down vote accepted

As I originally surmised and as others suggested, this turned out to be a hardware issue.

I solved the problem by updating both the SSD firmware and the SATA drivers for my motherboard. Since I did these steps at the same time, I'm not sure what actually fixed it. Given that I have several other disks on the same controller, it's likely that the firmware update fixed it.

Both updates required me to boot into Windows, which wasn't a huge issue for me since I already had it installed on a different disk.

share|improve this answer

For what I could read about all that you have done I am more certain that it is case similar to one I had about 4 months ago. The problem at the end was the SATA Cable. After changing it the I/O problems were gone.

Now this does not automatically mean this is the same issue as yours but since you checked the SMART data and even did a fsck on the drive (Which would have thrown a lot of I/O problems) I am more a favor of a hardware problem (Not related to the drive) than the actual SSD drive.

I would first, test the same drive on another computer. This means, different power supply, different motherboard, different SATA cable and power cable. Test that for the amount of time you need to make sure the SSD drive is the culprit. If the checks you did are all as you mention them, the SSD drive should work and have no problems at all.

If they are, then the chipset within the SSD is bad (Very unlikely).

After checking the SSD drive, start changing each important part, first SSD Cable, then motherboard and last the power supply.

In my case, like I said, it was the cable. In your case it could be any of the parts related/connected to the drive.

share|improve this answer

LEIGH BARTON Sectionalize, localize, and isolate the problem. My first step in assessing this problem would be to run the computer from an installation disk using the try ubuntu feature. Try to determine if the computer functions properly using the live operating system. If it does, then it's down to data storage/recovery system in the computer. If not, it's an issue with the computer itself, such as overheating. Assuming the live operating system functions properly, it becomes a hardware/software problem in data management. Your test results indicate that the hardware is functioning within specifications, bearing in mind that Solid state drives are relatively recent and still have some bugs to be worked out. That leaves software and the multitude of problems that can strike. That means data corruption, viruses, or program conflicts. The only feature of the operating system that shuts down the screen is the screen saver, try disabling the screen saver, tell it never to shut down the screen. I don't know what type of decontamination software you run on the computer, but I went for Clam-TK right after installation. Scan for viruses. Finally, there's the possibility of program conflicts, if you didn't install any programs just prior to these symptoms developing it's unlikely, and since I'm relatively new to LINUX myself I can't tell you what software to use to look for conflicts. You'll have to research that on your own. That's as much as I can offer.

share|improve this answer
1  
-1 This is incoherent. Can you please edit it to remove any unnecessary information? –  Tom Brossman Mar 10 '13 at 15:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.