Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASUS X55A-SPD0204O laptop. The rest of the FN+Fx (where x = number) like sound + - mute, screen turn off, wireless etc. work perfectly.

The problem is with the 2 brightness keys. They just won't work. Any suggestions?

share|improve this question
3  
Can you please add the output of ls /sys/class/backlight and of cat /sys/class/backlight/*/brightness to the question. –  mikewhatever Mar 20 '13 at 14:54
3  
I'd also be interested in seeing the output of lspci | grep -i vga, as we might be dealing with hybrid graphics. –  mikewhatever Mar 20 '13 at 15:03
add comment

7 Answers

Try adding acpi_backlight=vendor as a boot option. To do that, open a terminal window, and run

gksu gedit /etc/default/grub

Locate this line: GRUB_CMDLINE_LINUX="".

Edit it to look like this: GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

Save the file, then, in a terminal, run sudo update-grub.

Reboot, and check if the brightness keys work.

share|improve this answer
1  
Worked perfectly for my Asus UL50VT. Been trying to fix this problem for several years now. Thanks! –  unknownone Mar 10 '13 at 5:05
    
unfortunately this didn't work –  Dialogos Mar 10 '13 at 12:30
    
nope, doesn't work for me too. The indicator doesn't even pops up when i press those keys. –  AFwcxx Mar 20 '13 at 14:32
    
@Dialogos, try acpi_osi=Linux or acpi_osi=linux acpi_backlight=vendor; I hope one of these will help. –  AliNa Mar 21 '13 at 0:30
1  
Neither acpi_backlight=vendor nor acpi_osi=linux acpi_backlight=vendor worked for me. The working one for me was acpi_osi=Linux as @AliNa commented. Debian Wheezy on Asus UX50V Laptop –  Stichoza Jan 31 at 16:21
show 2 more comments

Upgrade the grub and try you may be able to get the brightness working properly. You may follow this link and to upgrade and fix the brightness problem for your PC.

share|improve this answer
add comment

Are you able to change the brightness in system settings (Power manager)? If yes, then maybe just keys are not binded.

You could install xbacklight and bind your special keys to appropriate commands.

share|improve this answer
    
yes i can change it manually. –  Dialogos Mar 22 '13 at 23:03
add comment

You can try to control it from command line and give mesage back if this works in general:

You will need xrandr

xrandr --current --verbose - this will display your current display mode / modes

important is name of your output (clould be LVDS1 or LVDS-0)

xrandr --output <outputname> --brightness 0.5 - this should control your brightnes, you can try different values. Do not use zero (0) what means lamp is switched off and you will see Big nothing. be careful, some types of devices have completely different set of values (as 0-255, etc. Unfortunatelly I do not have your ASUS to test it)

This will work probably independently of the brightness settings reachable normally via keys. If this works, I recommend to watch for key bindings. Advantage is, you can control brightness of external VGA output as well.

share|improve this answer
add comment

try that .. i had your same problem and it work with me

Open a terminal window and type the following:

sudo nano /etc/X11/xorg.conf

This will open your X server configuration (after prompting for your password). You should see a section titled "Device" that looks as follows:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
EndSection

Append a line so it appears like this:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

You will need to restart your graphical server (or reboot) for this change to take effect.

PS: I tried all suggested solutions here and nothing worked with me!

share|improve this answer
1  
there's no such file. –  Dialogos Mar 22 '13 at 23:05
add comment

it seems like there are 2 solutions for this problem, but sometimes none of these work. I tried changing the boot options (editing-updating grub and stuff) and that didn't work. As I have seen in many forums (and in my case too), the change in the xorg.conf file won't work because there is no such file... so?

After searching a couple hours, I found something interesting:

sudo nvidia-xconfig
sudo reboot

those lines supposedly get the driver working as it should, but the original problem remains. The important thing is that those lines CREATE the xorg.conf file, so now it is possible to apply the second solution (adding the Option "RegistryDwords" "EnableBrightnessControl=1" line to the file).

Hope this helps someone, I used this on a Samsung R580, with a Nvidia GeForce310m and worked just fine.

By the way, I used sudo gedit /etc/X11/xorg.conf instead of the nano command, it's just a matter of tastes I guess...

share|improve this answer
add comment

Try this app .. for problem in brightness controlling

https://apps.ubuntu.com/cat/applications/brightness-controller/

I was also searching stuff related to driver , but at last I found this app . I am having ubuntu - 12.04 on Sony - vaio, working fine for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.