Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a new HDD in my computer. I booted up and formated it in NTFS and copied about 500 GB of Videos onto it. My computer (few hours later) froze while a was watching a video off that drive.

I had to do a hard reset. Upon reboot the computer tried to boot of that drive which gave me an BOOTMBR missing error which I than followed by changing the boot order. Now that drives doesn't show up in my Unity Taskbar (to be mounted). The Disk utility now shows that the drive has 2 unallocated partitions and 2 partitions of unknown type and content (which previously only had 1 partition).

Disk Utility Image

enter image description here

Calling a fdisk for that drive gave me the following:

 sudo fdisk -l /dev/sdb
 [sudo] password for zereox: 

 Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
 255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
 Units = sectors of 1 * 512 = 512 bytes
 Sector size (logical/physical): 512 bytes / 4096 bytes
 I/O size (minimum/optimal): 4096 bytes / 4096 bytes
 Disk identifier: 0x2052474d

 This doesn't look like a partition table
 Probably you selected the wrong device.

 Device Boot      Start         End      Blocks   Id  System
 /dev/sdb1   ?     6579571  1924427647   958924038+  70  DiskSecure Multi-Boot
 Partition 1 does not start on physical sector boundary.
 /dev/sdb2   ?  1953251627  3771827541   909287957+  43  Unknown
 Partition 2 does not start on physical sector boundary.
 /dev/sdb3   ?   225735265   225735274           5   72  Unknown
 Partition 3 does not start on physical sector boundary.
 /dev/sdb4      2642411520  2642463409       25945    0  Empty

 Partition table entries are not in disk order

I haven't tried to format the drive as I hope to save something from it, but does anyone know of how to fix it?

share|improve this question
    
I was unable to salvage any data from the drive. I had to recreate a partition table on the drive and reformat it (Using GParted: Device -> Create Partition Table -> OK; Right Click Unallocated Space and press New). I choose to go with the default Ubuntu format: ext4. By going from NTFS to ext4 I saw a massive increase in the Read/Write speed of the drive as NTFS under Linux requires FUSE and isn't native to the environment. I was able to achieve ~20 MB/s under an NTFS partition and ~59 MB/s with an ext4 partition (Transfered a folder containing 10 .MKV files [SIZE:9.95GB]). –  Jason B Mar 10 '13 at 7:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.