Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a new to linux. I have an HP Pavilion DM4-1160US laptop. It has only one video card built-in (Intel HD), however Ubuntu seems to have a hard time with it.

It started when I tried to boot from a LiveCD - it booted into a black screen. Once I changed it "acpi=off" it booted up fine. I then installed Ubuntu 12.10 32 bit (wiping the HDD), however when I rebooted it was to a black screen again.

I did some research, noticed that my graphics show as "unknown" and installed mesa-tools through apt-get. It then showed my graphics to be "Intel® Ironlake Mobile x86/MMX/SSE2" but whenever I reboot it would again boot to a black screen. I tried installing (I think this is right) SNA from xorg but it still would not work.

I really want to get linux on my laptop but I am kind of at a loss here.

Please help!

share|improve this question

Chroot system from Ubuntu Live CD and in terminal type:

sudo mkdir /mnt/ubuntu
sudo fdisk -l
Find root partition (example: /dev/sda1).
sudo mount /dev/sda1 /mnt/ubuntu
sudo mount -t proc proc /mnt/ubuntu/proc
sudo mount -t sysfs sysfs /mnt/ubuntu/sys
sudo mount -o bind /dev /mnt/ubuntu/dev
sudo mount -o bind /dev/pts /mnt/ubuntu/dev/pts
sudo cp /etc/resolv.conf /mnt/ubuntu/etc
sudo chroot /mnt/ubuntu

Add to GRUB2 configuration file nomodeset flag. How to do this is here.

If that does not help, I recommend switching to a more stable version of Ubuntu 12.04 LTS.

share|improve this answer
well, I did as suggested and nothing works. I even tried going to 12.04 LTS and same issue there. nomodeset does not work for me (same black screen) but "acpi=off" does. Any ideas? – Ofer Mar 14 '13 at 5:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.