Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

On fresh Ubuntu install, the first thing i did was install the latest NVIDIA drivers. After reboot, unity disapeared. Only the mouse and the wallpaper were there. I was using 64-bit Ubuntu. How to fix this? PS i have desktop

share|improve this question

marked as duplicate by Eric Carvalho, Seth, Uri Herrera, Eliah Kagan, vasa1 Mar 10 '13 at 10:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
If you have a laptop, you probably have a Nvidia Optimus laptop. See askubuntu.com/q/36930/6969 –  Lekensteyn Mar 9 '13 at 22:09
    
You did not mention what hardware you have... –  Lekensteyn Mar 9 '13 at 23:08

1 Answer 1

You can remove the nvidia drivers you installed by typing 'sudo apt-get purge nvidia*' (This will remove all nvidia drivers installed), then reboot. If Unity is still not back at that point, type 'ccsm' to open Compiz (The window manager) and scroll down and manually re-enable the 'Ubuntu Unity Plugin', and resolve all the conflicts by disabling the conflicting plugins. Then reboot again, and it should be good

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.