Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While trying to make a DAAP server work, with tangerine, I realized that my music library doesn't has read permissions for all users, but has all the permissions for the owner and the group (tangerine needs read permissions for all users).

Thing is, my music is stored in a separate disk, with NTFS disk format, and no matter how much I use

sudo chmod -R 774 */folder*

the permissions do not change.

This disk is automatically mounted to a specific location (/windows/backup) thanks to fstab; the owner of the files in the disk is root and the group is plugdev.

The fstab is:

UUID=328ecc0c-b204-4450-a42c-ba64bc29e621 / ext4 errors=remount-ro 0 1
UUID=9189347c-056a-4860-ad6f-155d3a21fd90 /home ext4 defaults 0 2
UUID=F674A4C474A48947 /windows/backup ntfs defaults,umask=007,gid=46 0 0
UUID=867EA7097EA6F0DB /windows/main ntfs defaults,umask=007,gid=46 0 0
UUID=b5e4c040-5117-45c3-8b76-7fa29977eb80 none swap sw 0 0 

Thanks for your help.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Please have a look at man mount:

Mount options for ntfs [...]

uid=value, gid=value and umask=value

Set the file permission on the filesystem.
The umask value is given in octal.
By default, the files are owned by root and not readable by somebody else.

The solutions is to set the right mount options.

If you use the option umask=0002 the files can be read by everyone. But only the owner and group members may write to them.

Note: 774 <--> ug=rwx,o=r is not what you want.
If there is no "executable" bit for a folder you can't access it (e.g. cd folder will fail).

share|improve this answer
    
So what options should I use, @H.-Dirk ? my current setup in fstab shows that the umask value is 007, which should give other users all permissions... unless I'm passing something up, or such an option doesn't exists –  HaPK Mar 9 '13 at 20:43
    
@HaPK If you provide detailed information about your configuration, you have a change to get also detailed feedback. How about showing your fstab entry? BTW: 007 <--> ug=rwx,o=, so only member of the root group may access the mounted nfts partition. –  H.-Dirk Schmitt Mar 9 '13 at 20:49
    
hapk@twisto:~$ cat /etc/fstab UUID=328ecc0c-b204-4450-a42c-ba64bc29e621 / ext4 errors=remount-ro 0 1 UUID=9189347c-056a-4860-ad6f-155d3a21fd90 /home ext4 defaults 0 2 UUID=F674A4C474A48947 /windows/backup ntfs defaults,umask=007,gid=46 0 0 UUID=867EA7097EA6F0DB /windows/main ntfs defaults,umask=007,gid=46 0 0 UUID=b5e4c040-5117-45c3-8b76-7fa29977eb80 none swap sw 0 0 –  HaPK Mar 9 '13 at 20:56
    
That was it, that option for umask did change the permissions, but now the DAAP clients wont see my music library... that's for another question though –  HaPK Mar 9 '13 at 21:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.