Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have customized my keyboard layout by changing a line in /usr/share/X11/xkb/symbols/da (so my onehalf key is now a dollar - easier when coding in PHP).

My problem is that this change is not remembered by Ubuntu when I reboot - the file is not changed, but the key is now onehalf again.
If I go into "Keyboard Layout" in the system settings and then add a random language and remove it again, my own layout is back again.

Is there some sort of cache that I need to update?

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

It were a cache issue.

I fixed the issue by removing the xkm files in /var/lib/xkm.

sudo rm /var/lib/xkb/*.xkm

And then rebooting (I'm not sure how to regenerate the cache files without doing so).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.