Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I boot up Apache, this error occurs:

(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down

I've dug around the forums, and found the methods used to view all processes using port 80, such as:

lsof -i | grep http

and

lsof -i | grep :80

and then kill them. For some bizarre reason, nothing comes up when I run these checks, and even without the "grep", i still cannot find anything. I've tried reinstalling apache, including purging all the files.

share|improve this question

1 Answer 1

Invoke lsof -i:80 as root and you will see which processes using port 80.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.