Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been struggling with this for quite a while.
I have no sound at all (system sounds, login sound, rhythmbox, vlc, youtube etc.)

  • The system detects my audio card (POD Studio UX2)
  • I've tried 'sudo alsa force-reload', nothing.
  • No sound through headphones either.
  • I've checked everywhere, nothing is muted.
  • System Settings > Sound > Test Sound also produces no sound

Note: POD Studio UX2 is an external audio card by Line6.

Can someone please help?

share|improve this question
1  
run sudo alsamixer and make sure that your device isn't muted. –  nikhil Mar 9 '13 at 15:26
    
I have already tried this, but I can't find a mute/unmute option i178.photobucket.com/albums/w247/morgan-bailey/Screenshot.png –  MorganSBailey Mar 9 '13 at 15:57
    
Looking at your screenshot, everything looks correct. It shows you a M instead of a numeric value to indicate if a channel is muted. Do you have pulseaudio installed? –  nikhil Mar 10 '13 at 7:14
    
Yes, pulseaudio is installed. I don't know if that helps, but I can't actually mute anything in alsamixer (by pressing m) –  MorganSBailey Mar 10 '13 at 12:08
    
I used to have problems with pulseaudio, you can try sudo chmod -x $(which pulseaudio). After this restart. Might work, might not. To revert the change you can do sudo chmod +x $(which pulseaudio) –  nikhil Mar 10 '13 at 15:59

1 Answer 1

Audio trouble with Ubuntu some common checks

-- If you are using a laptop, your laptop may have a keyboard function to manipulate your sound.
Check that. Your laptop may have a keyboard control to mute, increase and decrease sound.
-- Please check your sound devices volumes are to a high level double click on the top right loudspeaker icon you will see a mixer
-- Please make common test from menu System->Preferences->Sounds

-- If you have two audio cards - please disable the on board audio card using BIOS setting, please check with this terminal command:

lspci | grep -i audio

-- Please be sure your pc are starting with the generic kernel press ESC at boot when you see the GRUB row then select the "kernel.... - generic" row
-- Please be sure all needed kernel modules are installed to make this check and install them:
So open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-ubuntu-modules-$(uname -r)

give your user password when requested, you don't see nothing when you type it, then press enter.

Then reboot your pc.

-- Be sure your user is member of audio group
Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo adduser $(who am i | cut -d" " -f 1) audio
sudo chmod 660 /dev/snd/*

give your user password when requested, you don't see nothing when you type it, then press enter.

-- Please try to watch what audio cards are detected on your system please type: asoundconf list

if more than one sound cards is detected by your system to set the default soundcard

asoundconf set-default-card PARAMETER

change PARAMETER with the name of a one detected sound card

-- Please try to delete making a backup copy of this conf files
mv .asoundrc .asoundrc_old
mv .asoundrc.asoundconf .asoundrc.asoundconf.old
sudo mv /etc/asound.conf /etc/asound.conf.old

Please take a look at this http://ubuntuforums.org/showthread.php?t=205449

-- Please try to discover if there are any process they are keeping the /dev/dsp locked ps -edalf | grep -i dsp

kill them using this command:

kill -9 number_of_pid


If you microphone seems don't record your voice please open a terminal and type

alsamixer

and press tab to switch in view to [Capture] section, and then pressing space on mic and mic boost aid

If you are using Pulseaudio and you have some sound issue with sound apps please read http://ubuntuforums.org/showthread.php?p=4928900

Hope this helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.