Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I am new to ubuntu. So I tired to install a software by typing the 'make install'. this error is occurred. Please help me.

cd src && make CC='gcc' CPPFLAGS='' DEFS='-DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/usr/bin//etc/wgetrc\" -DLOCALEDIR=\"/usr/bin//share/locale\"' CFLAGS='-O2 -Wall -Wno-implicit' LDFLAGS='' LIBS='' prefix='/usr/bin/' exec_prefix='/usr/bin/' bindir='/usr/bin//bin' infodir='/usr/bin//info' mandir='/usr/bin//man' manext='1' install.bin
make[1]: Entering directory `/home/praneethpj/wget1.5.3/src'
gcc -O2 -Wall -Wno-implicit  -o wget  cmpt.o connect.o fnmatch.o ftp.o ftp-basic.o ftp-ls.o ftp-opie.o getopt.o headers.o host.o html.o http.o init.o log.o main.o md5.o netrc.o rbuf.o recur.o retr.o url.o utils.o version.o 
/usr/bin/ld: h_errno: TLS definition in //lib/ section .tbss mismatches non-TLS reference in ftp.o
//lib/ could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [wget] Error 1
make[1]: Leaving directory `/home/praneethpj/wget1.5.3/src'
make: *** [install.bin] Error 2
share|improve this question

marked as duplicate by Web-E, hhlp, vasa1, Eric Carvalho, con-f-use Mar 11 '13 at 11:58

This question was marked as an exact duplicate of an existing question.

Please let us know, which software you are trying to install. – Web-E Mar 9 '13 at 12:44
hi, when i install any software this error is showed.after typing the make or make install command – Praneeth Pj Mar 11 '13 at 7:13
that is my point, install from software center. Use make stuff only when the software is not present. – Web-E Mar 11 '13 at 7:56
i think ,I solved this.I installed the perl.and I update the Ubuntu is done – Praneeth Pj Mar 11 '13 at 9:19
still my point is valid. Avoid install from source as much as possible. Every time there is a breaking changes to any of it's dependency , you installation will break and you have to compile again. – Web-E Mar 11 '13 at 9:41

sudo apt-get install firefox
this is through terminal
if you want to install it via GUI then ubuntu software source is a good Repositories type what ever software you want to install and install,another way is through synaptic package manager for more details on this read

share|improve this answer
problem solved the reason of UBUNTU version. i changed the Ubuntu 10.10 to 12.10 – Praneeth Pj Mar 14 '13 at 11:43

To install a software using the source code, as you're trying to do, normally requires 3 commands. Following are the steps, you need to follow:

  • Move to the directory containing the source code.
cp /path/to/source/code
  • Look for file named README or INSTALL. The file, if present, would probably contain install instructions.

Otherwise, you can also look at the website from where you downloaded the source to get the information.

  • If you don't want to do so, which I do recommend doing, run the following commands:
    sudo make install
  • You might get error at ./configure, which would mean that either configure file is not present, in which case you should read the installation instructions, or there can be some dependencies which need to be installed first.

Or, of course, they can be just some warnings that won't mean much depending on the use case.

share|improve this answer
I was followed this steps.but it is happend.the error showed after typing the 'make' or 'make install' command – Praneeth Pj Mar 11 '13 at 7:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.