Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to make an application and package it and so on, but I have run in to a lot of errors, so I tried to get back to basic:

after the command quickly create ubuntu-application dj1 and cd dj1 I get my app, which can run and package with quickly package, works fine!

Although I get some warnings that

** (setup.py:5609): WARNING **: Error sending credentials: Error sending message: Operation not permitted

but I've read that one should state your name and such in the setup.py file at the bottom. So I did quickly edit and had to open the setup.py file separately and wrote my license, name, email, description and long description at the appropriate places (i did not include a web page). I saved and terminated gedit.

now when I run quickly package I get

.......

Command returned some WARNINGS: ---------------------------------- WARNING: the following files are not recognized by DistUtilsExtra.auto: setup.py~ ---------------------------------- Do you want to continue (this is not safe!)? y/[n]: n

I've read on this forum that one can downgrade python-distutils-extra to the last stable verison with:

sudo apt-get install python-distutils-extra=2.32-2

but after I did that and tried to package again i got the same warnings. (and I also read that one should not simply remove the setup.py~ file)

Does anybody know how to get rid of these warnings? Am I using the edditor in a wrong way? I tried before and used emacs, but same thing there...

I'm running Ubuntu 12.04 LTS.

Thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Whatever editing program you used to change setup.py created a backup setup.py~ of the original file. When the program is packaged by distutils, file types that it doesn't recognize (i.e. the .py~) give a warning. Just delete the file. Not sure how to turn off that behavior in whatever editor you're using.

EDIT: In gedit you can turn off automatic backups by going to Edit->Preferences->Editor tab and unchecking 'Create a backup copy of files before saving'

share|improve this answer
    
This time, I used gedit (the default editor for "quickly edit") but I've also used Emacs, with the same result... –  user136459 Mar 11 '13 at 8:01
    
I edited the answer to show how to turn off this feature in gedit. –  Ian B. Mar 14 '13 at 14:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.