Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I installed Ubuntu Server 12.04.2 LTS i386 version on my old AMD Athlon 2000+ PC... The thing is I don't have access to internet. I cant even execute sudo apt-get update... An I cant ping www.google.com

During installation I put the local IP 192.168.1.175, Subnet 255.255.255.0, nameserver from my ISP 194.146.109.223 and I left PROXY empty and I jut pressed enter after the proxy. Now I don't have any acces to internet from server and I can't update my machine...

Is it because I didn't put any PROXY address???

share|improve this question
    
Are you bihind a proxy? Can you provide info about the internet connection. –  mikewhatever Mar 9 '13 at 11:50
    
As above, please edit the question to include information about your networking hardware (lspci -nn | grep net) and let us know how your network is configured. I suspect you've set a static IP and your router wants to give you a dynamic IP. –  Oli Mar 9 '13 at 11:53
    
00:0d.0 Ethernet controller [0200]: Realtek Semiconductor RTL-8139 (rev 10) –  tehnikalac Mar 9 '13 at 11:57
    
00:13.0 Ethernet controller [0200]: Realtek Semiconductor RTL-8139 (rev 10) –  tehnikalac Mar 9 '13 at 11:58
    
I logged into my router and configured manually that my DHCP always gives me IP 192.168.1.175 for my server. Even during installation I set IP for server 192.168.1.175 –  tehnikalac Mar 9 '13 at 11:59

1 Answer 1

Per my comment above, it sounds like you've configured something you should have left as automatic. I would run sudoedit /etc/network/interfaces and make the file look something like this:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

Save that and run sudo /etc/init.d/networking restart or sudo restart networking (I can't remember if 12.04 is Upstart-converted). Assumign the ethernet device is supported, that should tell it to ask for a dynamic IP.

If you want to statically assign an IP (often a desirable thing for a server) I would get the DHCP server on the router to set your server's IP to the same thing each time. Most routers allow this sort of soft-static addressing by MAC address.

share|improve this answer
    
I ran sudoedit /etc/network/interfaces and this is what my data says:sudoedit /etc/network/interfacesnet static address 192.168.1.175 netmask 255.255.255.0 network 192.168.1.0 broadcast 192.168.1.255 gateway 192.168.1.1 #dns-* options are implemented by the resolvconf package, if installed dns-nameservers 194.146.109.223 dns-search server.home.org auto eth0 iface eth0 i –  tehnikalac Mar 9 '13 at 12:01
    
I assigned IP for server na router manually: 192.168.1.175 –  tehnikalac Mar 9 '13 at 12:07
    
Now when I ping 192.168.1.1 it says Destionation Host Unreachable –  tehnikalac Mar 9 '13 at 12:08
    
Now I cant see my server on router –  tehnikalac Mar 9 '13 at 12:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.