Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu 12.10. My PC isn't auto detecting my drivers, I've tried installing the graphic drivers from the additional drivers section, but it shows nothing.

when I open up the "About this computer" tab, I see that my graphics driver is UNKNOWN and my experience is STANDARD. After referring to a lot of forums, I saw that I had to run this command,

lspci | grep VGA 

I see this output

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev a1)

I have tried downloading nvidia's graphic driver file, but it's a .run file and I don't know how to install it.

How do I fix this?

share|improve this question

Did you try change the drivers via GUI mode? You can do it via Software Center. Press menu "Edit" > "Software sources" and then the tab "Additional Drivers". It should offer you a easy way to change or update drivers detected.

share|improve this answer
I did, but that doesn't work, drivers weren't detected. it says no proprietary drivers are in use. – treppenwitz Mar 9 '13 at 1:41
If this is one of those hybird cards, I think this is a duplicate of the following:… If not a hybird card, this similar question and answer should help:… – Mordoc Mar 9 '13 at 2:00
Thanks for your response. I think it's a hybrid card, and I have tried the solution, but it doesn't seem to help. Any more help would definitely be appreciated! – treppenwitz Mar 9 '13 at 4:26
I think I could give you some instructions on how to use the *.run file via a TTY to install an nVidia-driver manually (which I do regularly, as the GUI options didn't work for me since 13.10 and installing the driver manually did). But the linked answer above warns against this as it seems. However, if you want to take the risk, let me know. – Mrokii Mar 9 '13 at 10:47

See the Nvidia instructions:

Installation instructions: Once you have downloaded the driver, change to the directory containing the driver package and install the driver by running, as root, sh ./

This should do the trick.

share|improve this answer

You have hybrid graphics card, Intel+nVidia. Intel for power saving and nVidia for performance. I solved the problem and answered it in here: in here

The process worked for my laptop and tested on Ubuntu 13.04 and 13.10

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.