Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a TP-LINK WN821N and two computers, both with 12.04 LTS and 12.04.2 LTS. The computer with 12.04 does not have graphical environment, I tried network-manager but did not work so I installed wicd (with wicd-cli and wicd-curses). The former, with 12.04.2 does have a graphical interface.

I can easily connect to an ad-hoc with the network-manager in the graphical interface, but I cant connect to an ad-hoc network using the same wireless card in the wicd computer. The problem is, the device appears with lsusb (atheros...), if I run nmcli it says the device is unavailable (although the wired network works perfectly) and when using wicd it doesn't go any further from the "getting IP address.."

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.