Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am trying to print a custom paper size of 105.00 inches x 23.39 inches (the GLDT for my office :D). Whenever I try a custom paper size, the job sits in the queue with the message Processing - Not Connected?

If I print to a standard paper size, it prints no problem. I am printing to an Epson Stylus Pro 9900 and have tried IPP, LPD, and Socket 9100 works best, but still no go on custom paper size jobs with any of these. I have tried a variety of custom sizes. Printing is not a problem when selecting existing paper sizes. I am using the only available drivers which seem to be available Epson Stylus Pro 9900 - CUPS+Gutenprint v5.2.8-pre1 and come in 12.04 no problem.

The only manual solution I can come up with is to edit the picture and make separate pages and print them out to scale as much as possible and piece them together...bleh.

Anyone aware of a fix? I did much rather have a working solution than manual labor. Thanks.

share|improve this question
    
Related: askubuntu.com/q/264651/169736 –  Braiam Aug 18 '13 at 12:36
    
hm - it is difference about gimp 2.8 and gimp 3.x (upwards) ... gimp is eatening itself up like a cannibal zombie ... on dual-boot with windows. –  dschinn1001 Jun 5 '14 at 4:11
    
@Braiam thanks, didn't help. Even when making my custom plotter size settings into a "standard/preset" format I could choose from. :( –  TryTryAgain Nov 6 '14 at 22:08
1  
long shot, but is that thing postscript compliant? I had an old brother that would do the same thing. Only way I resolved it was switching to a postscript driver. (I'd look myself, but as it would seem, the Epson Americas site is down for maintenance) –  Matt Barnes Nov 11 '14 at 6:48
1  
@MattBarnes it looks like you are right. Supports Adobe Postscript 3 (source: epson.com/_alfresco/proimaging/products/StylusPro79009900efi/… ) Write it up as an answer? –  Elder Geek Jan 7 at 1:54

1 Answer 1

First, lets get to know what your printer will do:

$lpoptions -d <printer-name>

then assuming your printer can handle your desired resolution etc... we can try to print. --What if is says it can only do 300DPI but you KNOW the printer can do more? well, maybe try reinstalling the printer with a better, more updated, non-generic driver. Then re-investigate the options that gives you.

now try giving the command:

$lp  -d <printer-name> -o PageSize=Custom.266x59cm <file.name>

Note: yeah, I know that 105'x23.39' isn't exactly 266x59cm but I'm not certain it will take decimals in there. I've also never tried using "in" for inches. it might exist, though I didn't read it in the manpages.

post results or errors.

share|improve this answer
    
It may be interesting to know the output of $df /var/spool odd things can happen if spool overflows. –  j0h Jan 21 at 20:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.