Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How could I setup a dual boot for Ubuntu and Windows 8 on my Microsoft Surface Pro with 128 GB.

Note: My dual boot solution is below.

share|improve this question
add comment

1 Answer

up vote 45 down vote accepted

Video Demo

EDIT: Aug 23, 2013 @ 11:00AM PST

Update WiFi resolved.

Updated for official 13.04 amd64 release. Changes made to this guide reflect the issue of not being able to get grub to load after install.

Please note that you cannot set the themed boot-loader and must use the grub default menu. I have removed this part of the guide. Here is the details.

The network manager is now fixed with several patched images and can be found in Step 7. The automate process explained by @Alp Dener only worked for 12.10 and will not work for 13.04 and up.


First

Create a partitioned drive.

  • Press search button on your keyboard type 'boot'.
  • Select 'settings >> Create and format disk partitions'

enter image description here

  • Select C drive, right click and select 'shrink volume'.
  • This is your choice but I use appox. 29.3 Gigs(30,000 MB): Shrink respectively.

enter image description here

Second

Follow the instructions on Geek.com.

  • Stop at prompt to delete disk or partition.
  • Return and follow instructions.

    note: I suggest using your SD drive as there seems to be USB compatibility issues in some cases. Also you can simply mount the ISO in windows and copy the contents to the storage drive, SD or flash.

Third

Prepare partitioned space for install.

  • Change the selection from 'Delete and Install' to 'Something Else' at the bottom.

enter image description here

  • It will ask if you want to unmount your installation device. Select 'No'.
  • Now select the free space and press the '+' button under the partitions.
  • Select from the drop list 'swap' and select the 'logical' radio button and 'insert at beginning' and finish. Select anywhere from 400 to 600 MB to be safe at least.

enter image description here

  • Now select the free space and press the 'change' button - again.
  • Select from the drop list 'Ext4' and select the 'primary' radio button, 'insert at beginning', 'format' button checked and '/' as root and finish. Use the remaining space you have reserved.

enter image description here

  • Finish install process on the Ext4 partition you created.

!!!Do not restart, click the Continue Testing button.!!!

Fourth

Make sure Grub2 was installed without problem.

sudo apt-get install grub2-common
sudo update-grub2

Setup Grub2 boot repair and run.

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair
sudo boot-repair
  • Select 'Recommended Repair'.
  • Restart to make sure you see the boot loader. If you wish to make the 10 second count shorter or longer, go back to boot-repair and select 'Advanced'.

enter image description here

Now you can restart.

Fifth

Marvell Wi-Fi Fix is needed to continue to the next step until I or someone else create a better option. Fix Ref

Decompress contents of this file* to Desktop then run the following:

cd Desktop
sudo cp mrvl/* /lib/firmware/mrvl
sudo modprobe -r mwifiex_usb && sudo modprobe mwifiex_usb

Edit the /etc/network/interfaces file by running:

cd ../../..
cd etc/network
sudo gedit interfaces

Add the following after 'iface lo inet loopback'

iface mlan0 inet manual
iface uap0 inet manual

Create connection settings

sudo service network-manager stop
cd .. 
sudo gedit wpa_supplicant.conf

Use the following template to paste into the file. Edit for your network and save.

ctrl_interface_group=0
ctrl_interface=/var/run/wpa_supplicant
network={
    scan_ssid=1
    ssid="mySid"
    key_mgmt=WPA-PSK
    psk="passwordGoesWhere?"
}

Restart computer. Run the following every time to start Internet.

sudo /sbin/wpa_supplicant -dd -imlan0 -c/etc/wpa_supplicant.conf -Dwext,nl80211

Minimize that terminl and don't close. Open New terminal and run:

sudo /sbin/dhclient mlan0

Now you should have fast reliable Internet for your current session so you can continue.

Sixth

The Intel i5 needs a fan sensor update. I suggest doing this with lm-sensors as suggested here.

sudo apt-get install lm-sensors
sudo sensors-detect
  • Select 'YES' to everything and follow the end instruct
  • It will ask you to run some sudo commands after it is done.

Seven

You will need to install the linux-image-3.11.0-3-generic_3.11.0-3.7~lp1212720v1_amd64.deb and linux-image-extra-3.11.0-3-generic_3.11.0-3.7~lp1212720v1_amd64.deb packages to fix the WiFi issue. Just download and double-click to use the Ubuntu Software Store to install.

Thanks to Tony S. Hariman for staying on this bug issue and Joseph Salisbury for the patches.


Ubuntu Developers

Help me solve the themed boot-loader issue.

Before the 13.04 release you were able to custom theme the boot-loader as the below image demonstrates. The previous instructions I had for this can be found here: my github.

We want boot themes!

share|improve this answer
2  
if you have the pictures, upload them on a site and then we will add them if you don't have the reputation! Great answer btw! :) –  Alvar Mar 8 '13 at 21:18
1  
@BrandonClark Great! It only takes 10 rep to post pictures. If you need anything else, feel free to hop into chat and ask! Great answer :D –  Seth Mar 8 '13 at 21:22
2  
Why are we formatting the partition as FAT32 only to format it as EXT4 later? Isn't that pointless? –  Nathan Osman Mar 9 '13 at 2:19
    
Your screenshot suggests that gparted is simply reformatting the partition as EXT4 instead of converting from FAT32 to EXT4 (which is impossible as far as I know). –  Nathan Osman Mar 9 '13 at 3:01
1  
@Mittenchops There is a bug currently that makes my system have the same issues but only from time to time. You may want to try and reboot a couple times or you may have had something go wrong in the installation process and may need to delete what you have done and try again. I will suggest downloading the daily image for 14.04 though as I seem to be having less bug issues. I will be adding an update soon to reflectt installation of 1.04 only. –  Brandon Clark Mar 17 at 20:53
show 17 more comments

protected by Community Jun 16 '13 at 3:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.