Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As you can see from the subject, I am getting an error from the latest version of xnoise after install. I have tried installing gstreamer 1.0 good, bad and ugly plugins. I am using Ubuntu 12.10 64-bit.

Any ideas as to a solution?

share|improve this question
add comment

put on hold as unclear what you're asking by Braiam, Seth Apr 16 at 16:28

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

I got the same error message from Totem after upgrading my ALSA-only system from Quantal to Raring. (I removed PulseAudio long ago because it causes intolerable problems.) Turns out the new version of Totem uses gstreamer1.0 instead of gstreamer0.10, and although I've had the gstreamer0.10-alsa installed for a long time, the upgrade process wasn't smart enough to install gstreamer1.0-alsa when it was installing the other gstreamer1.0 packages.

Manually installing gstreamer1.0-alsa made Totem work again.

share|improve this answer
add comment

In my case, installing gstreamer1.0-plugins-good fixed the issue, because autoaudiosink is part of that package.

share|improve this answer
    
Thanks for the reply, but I already have it installed. Very weird. –  globetrotterdk Mar 10 '13 at 11:39
add comment

The probable problem is that you are using ffmpeg (real ffmpeg not the transitional package in the ubuntu repository) and that may be conflicting with gstreamer-ffmpeg. Please remove the ffmpeg and the associated libraries (x264, libopus, fdk-aac, libvpx, yasm)

you could reinstall/compile it after you have installed xnoise.

NOTE:

I apparently also had the same issue, which was removed using the above method.

share|improve this answer
add comment

I had this problem and after installing gstreamer1.0-pulseaudio Install gstreamer1.0-pulseaudio, everything is working. I recommend installing that package.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.