Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh install of Ubuntu 9.10 on a rented dedicated server.

When I ssh to it using PuTTY (on a Windows machine), I find it responds to Ctrl+S and
Ctrl+Q as XON/XOFF transmission control (i.e. the terminal freezes everytime I type Ctrl+S until I type Ctrl + Q).

This hasn't been a problem on other remote servers, and I realise I don't really have much idea about how this is determined. Is this something that is negotiated at the start of the terminal session, something that is set by the choice of terminal emulation (TERM=xterm, if that helps) or - as I suspect - some setting on the server I am not aware of.

How do I tell Ubuntu that it is 2011, and no-one has terminals that rely on XON/XOFF any more?

share|improve this question
    
I still use xon/xoff. I often view log streams from webservers, looking for exceptions and errors. It is very convenient to stop the terminal and then scroll back to view the error. Think of it as a terminal tivo (without the skipahead). –  Arcege Feb 16 '11 at 1:25

1 Answer 1

up vote 3 down vote accepted

Based on a SuperUser question, just run this once connected:

echo "stty -ixon" >> ~/.bash_profile
reset

And that should fix it.

(Updated to correct option)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.