Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problem installing the nvidia drivers for my GPU, Nvidia Tesla C2050. I have tried to use both the drivers from Nvidia and the drivers from Ubuntu

I have been advised to use the drivers from ubuntu so the latest thing I tried is the following:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

What happend is that if I after a fresh installation of Ubuntu 12.04 tries to do

sudo apt-get install nvidia-current nvidia-current-dev

I first get the message that it cannot be installed because it says something like: missing dependencies xorg-video-abi-11 and xserver-xorg-core

so I install them using

sudo apt-get install xorg-video-abi-11 xserver-xorg-core

then I use

sudo apt-get install nvidia-current nvidia-current-dev
sudo apt-get dist-upgrade
sudo reboot

and now when I press CTRL-ALT-F1 it is just black and the screen goes in sleeping mode or it is just a black screen with white dots on it.

I have tried for three days now to install nvidia correctly so that I can install CUDA later for my research.

I basically want CUDA to work without any problems, maybe I should just install CUDA directly using the NVIDIA-drivers?

Any help would be appreciated! For instance what drivers to use, ubuntus or Nvidia's.

/ Erik

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.