Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The network service in my computer (Ubuntu LTS 12.04, upgraded) suddenly stopped working. The only clue in /var/log/syslog are lines like this,

Mar  8 16:51:51 Rafid-Hamiz-OptiPlex kernel: [   14.617413] init: network-manager main process (879) terminated with status 127
Mar  8 16:53:56 Rafid-Hamiz-OptiPlex AptDaemon.NetMonitor: WARNING: Failed to determinate network state

(Just before that time I remember running nmap (http://nmap.org/) once without root privilege, zenmap (http://nmap.org/zenmap/) once with root privilege. Are these connected in any way?)

I use a static address wired network with fixed MAC.

Even ping to my NIC address shows that the network process is not running.


service networking status

showed that the service is stopped.

service networking restart

did not improve the scenario.

Rebooting the machine was of no help either.

When I tried to set the network from System Settings, I got message in the line of "the network type is not consistent or some such". I forgot to take a screen shot.

None of the user accounts in this machine can get network. Even the network icon does not appear.

Now, when I booted the machine with Ubuntu CD (the same 12.04), and set the network parameters (IP address, MAC, gateway) just like my original one, network started working. This is how I am asking this question.

I do not know even where to start the remedial process. Which setting got corrupted in my machine? How do I get network service in the original machine and stop working from CD?

Any help will be appreciated.

share|improve this question
Perhaps I could try reinstalling network manager as elucidated in ubuntuforums.org/…. Any idea how do I do this with no working network connection? –  MMA Mar 8 '13 at 13:45
Reinstalling NM solved the problem. The sequence was, boot with Ubuntu CD, use synaptic to generate package script (askubuntu.com/a/262712/82650), download the .deb files, save these in a USB drive, reboot the computer normally, copy the .deb files to /var/cache/apt/archives/, execute sudo apt-get purge network-manager network-manager-gnome, check the warnings while executing the last command, execute sudo apt-get install network-manager network-manager-gnome, reboot the machine and configure network. I would still like to know what made my network connection get corrupted. –  MMA Mar 8 '13 at 14:58
Running nmap again, without root privilege did not cause any problem. I still would like to know the reason. –  MMA Mar 8 '13 at 15:46
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.