Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have lost all Desktop icons after updating on 6 March. I updated from Canonical's archive directly as I thought they would test software before they release it. When I run gnome tweak tool it says there are no extensions installed. They were all there on 5 March but not on 6 March after update.

I tried to download them again but they are greyed out and will not install.

How can I get my icons back in gnome shell?

Thanks.

The only desktop that works is gnome classic (no effects) all the others are blank with a mouse pointer that moves but does nothing.

share|improve this question
add comment

1 Answer

Solved: The problem was an incompatibility between gnome shell and nvidia's driver version 310. I uninstalled the driver and installed nvidia-current from the ubuntu archive. All the icons are back and I can install new extensions again. Rob Key

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.