Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i hope someone can help me with this, it was the story of today for me:

Everything was going ok and my internet worked perfectly for every device I had (computer, tablet, phone) except for my two Nexus 4. The wifi wasnt working. So after many many things I upgraded my routers firmware and now they are working! The problem now is that my Ubuntu 12.10 laptop connects to wifi but has no Internet! The same laptop on WIndows 8 works fine on wifi and the wired connection works fine on Ubuntu.

cant ping my router, but It says that Im connected (full strength)

By reading other posts I saw that usually they are required to post the output of the following commands:

lspci -nn | grep 0280

08:00.0 Network controller [0280]: Atheros Communications Inc. AR9462 Wireless Network Adapter [168c:0034] (rev 01)

ifconfig

eth0      Link encap:Ethernet  HWaddr d4:be:d9:78:2b:f5  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:20407 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20151 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:11477177 (11.4 MB)  TX bytes:2805826 (2.8 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5712 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5712 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:562475 (562.4 KB)  TX bytes:562475 (562.4 KB)

wlan0     Link encap:Ethernet  HWaddr a4:17:31:3a:9d:99  
          inet addr:192.168.0.106  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::a617:31ff:fe3a:9d99/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11328 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13289 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8270439 (8.2 MB)  TX bytes:2182573 (2.1 MB)

EDIT:

cant ping my router, but It says that Im connected (full strength)

netstat -rn

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0
share|improve this question
    
Check with google DNS , 8.8.8.8 –  Qasim Mar 8 '13 at 6:48
    
did you try a ping ping -c 3 google.com can you post the result. check your proxy settings.does your wireless provider use mac filter or something? try matching the hwaddr with the mac address below your laptop. your device seems to get an ip address. –  Anam Ahmed Mar 8 '13 at 6:55
    
@XxxXxx I followed these instructions developers.google.com/speed/public-dns/docs/using and no changes! –  fersarr Mar 8 '13 at 12:14
    
@AnamAhmed this is what I get :s... its weird,DNS? ping: unknown host google.com. And no, I have disabled MAC filtering. And no proxies. –  fersarr Mar 8 '13 at 12:15
    
Could you post the output of netstat -rn? –  jeremija Mar 8 '13 at 19:50

2 Answers 2

The simplest thing I can offer - is to remove the connection from NetworkManager and try to configure it once again.

Also try to remove this first:

169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 wlan0

from your routes.

share|improve this answer

You could try remove you internet connection, and then from command type set net_default_server=(hd0) , and then type ipv6_autoconf from command, and then ns_lookup also from command, and then install the wifi again.

share|improve this answer

protected by RolandiXor Jan 9 at 15:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.