Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I hope you are all well. Here's my problem.

I was running Ubuntu 10.04, and I got Mullvad , a VPN service because it is anonymous and cheap.

Mullvad VPN service installed perfectly on 10.04 and I used it for a couple of months without any issues.

In January I installed Ubuntu 12.04 via upgrade from 10.04, leaving Mullvad installed. Everything still worked properly.

Recently, however, with no changes to the software (as far as I know other than Ubuntu updates) Mullvad isn't working correctly. It says it's connected, but without the green checkmark indicating this which was previously displayed in 12.04 and 10.04. I could browse the Internet until about two days ago.

My subscription expired, and I started up Mullvad (but without the option to block connections on failure, because I was not a subscriber). I still left Mullvad installed, however. Later I restarted my computer, and this time did not start Mullvad/VPN at all. I could no longer access domain names, except for by typing in IP addresses of sites. I searched via startpage, and I found a couple articles. Apparently, I was supposed to move /etc/resolv.conf. EDIT: I followed the post here and did this: sudo mv /etc/resolv.conf /etc/backup.resolv.conf

I did this and now cannot access DNS. Thank you in advance.

share|improve this question
add comment

1 Answer

Mullvad has futzed with /etc/resolv.conf. If I understand correctly you are no longer using Mullvad. Disable and/or de-install Mullvad. Then, to restore resolv.conf,

sudo dpkg-reconfigure resolvconf

and reboot.

Background: The Mullvad component /usr/share/mullvad/dnsconfig.py moves /etc/resolv.conf away to /etc/resolv.conf.pre-mullvad and writes a new /etc/resolv.conf. This presumably happens just after the VPN connection is established. To clean up, it moves /etc/resolv.conf.pre-mullvad back to /etc/resolv.conf. The problem with this is that in Ubuntu 12.04, /etc/resolv.conf is a symbolic link which should never be touched; programs like Mullvad should interface with resolvconf to update the resolv.conf file. If the machine is ever rebooted without Mullvad being stopped cleanly then the symbolic link is gone and /etc/resolv.conf is an obsolete file. Bad. To repair the damage (as I already said) run sudo dpkg-reconfigure resolvconf and reboot. To avoid recurrence, either don't run Mullvad, or contact the Mullvad developers and ask them to make Mullvad interface with resolvconf, or edit /usr/share/mullvad/dnsconfig.py yourself to do that.

share|improve this answer
    
Hi, Thank you for the advice. I did this and the terminal gave the following error: resolvconf:Error: /etc/resolv.conf isn't a symlink, not doing anything. Please help. –  Anonymous Mar 22 '13 at 15:41
    
Thank you for the advice @jdthood. I followed your advice, and the terminal gave me an error: "resolvconf:Error:/etc/resolv.conf isn't a symlink, not doing anything." I think It has to do with what I did. I edited my question, because I had used the following code (which was missing from the original post): "sudo mv /etc/resolv.conf /etc/backup.resolv.conf" Thank you! –  Anonymous Mar 22 '13 at 15:58
    
Do sudo ln -nsf ../run/resolvconf/resolv.conf /etc/resolv.conf to restore the symlink directly. –  jdthood Apr 3 '13 at 21:11
    
Thank you for all your help! It now works! –  Anonymous Apr 8 '13 at 2:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.