Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 on my laptop and erased Windows 7. All has been working well, installing things, rebooting it multiple times. But now I got back on it and restarted it and suddenly the mouse doesn't work.

The keyboard works fine, I can type. And I can even click the mouse. I just can't move it around at all on the touchpad, or even with a USB mouse.

I've read a lot of different questions about this, but I haven't found any good answers. I've read that for some people the mouse activates after like a minute, so far mine hasn't been doing that. I also read about this problem being caused by the Video drivers in some way, and that would make sense, because I did download a driver for my video card before this happened.

But if that is the case, what do I do then? Thanks for the help!

share|improve this question
add comment

1 Answer

Just also had the mouse mostly stop working on 12.04 64-bit (could still click on app icons to open them, but could not use mouse to drag them, resize, or do anything else with the mouse -- also could not click on "settings" icon -- BTW, not running Unity here -- sudo apt-get install gnome-panel instead). Tried resetting the wireless mouse connection and tried new batteries. Didn't help. lsusb in terminal window showed "Bus 008 Device 002: ID 046d:c50e Logitech, Inc. Cordless Mouse Receiver" so looked ok. What did fix the problem for me was unplugging the wireless mouse USB connector from the computer and plugging it in again. Plugged it into a different USB port. Don't know if that mattered. Might give that a try.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.