Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sorry for my spelling and grammar errors, english is not my native launguage.

I need to run VMware-Player-3.1.5-491717.i386 in lubuntu. It has to be that version only, cause my motherboard architecture is 32bits. Thats why I cant use newer versions of vmware player.

I download this patch: vmware workstation 7.1.5 / player 3.1.5 fix for linux 3.2+ (patch by Ariel), I extracted and put in in my home folder.

From this website: weltall.heliohost.org

My steps:

1) Ok, so I already install VMware-Player-3.1.5-491717.i386

2) If I start VMware-Player-3.1.5-491717.i386 I get this error message:

VMware Kernel Module Updater, before you can run VMWare, several modules must be compiled and loaded into the running kernel.

3) Ok so time to use the patch

4) I put on terminal this commands:

sudo apt-get install build-essential linux-headers-`uname -r` 

 sudo chmod +x VMware-Player-3.1.5-491717.i386.bundle 

 sudo ./VMware-Player-3.1.5-491717.i386.bundle 

 sudo apt-get install patch 

 sudo ./patch-modules_3.2.0.sh 

5) It finish the hole process succesfully and it patch it. But when I try to run vmware player, I still get the same error. Before with old kernel it worked properly and I was able to run it with no problems. But with new Lubuntu kernel, now I get the error message, and wont get away.

VMware Kernel Module Updater, before you can run VMWare, several modules must be compiled and loaded into the running kernel

6) I noticed that the patch I download has 2 files:

a) patch-modules_3.2.0.sh

b) vmware-715-kernel32.patch

I am able to run patch-modules_3.2.0.sh properly, and I am able to install it succesfully, but I dont know how to install or run vmware-715-kernel32.patch.

I getting the feeling that, this is why I am getting the errors message, because I havent install properly the vmware-715-kernel32.patch

Any ideas of what command I need to run in the terminal in order to run vmware-715-kernel32.patch, and been able to patch the kernel succesfully ?

share|improve this question
add comment

2 Answers

Syntax for patch an application is :

sudo patch `which [APPLICATION]` [DIRECTORY]/[PATCH FILE.patch]

In your case :

sudo patch `which vmware-player` [DIRECTORY]/vmware-715-kernel32.patch
share|improve this answer
add comment

You might find the below command necessary to actually kick off the recompilations:

sudo vmware-modconfig --console --install-all

(after patching of course)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.