Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading some packets (that I don't know what), my ext4 partitions are mounted as read only:

m@mpc ~ $ sudo mount /dev/sda5 /mnt
mount: warning: /mnt seems to be mounted read-only.

My NTFS partitions are mounted as read only too and when I want to use fsck it says:

m@mpc ~ $ sudo fsck /dev/sda5 
[sudo] password for m: 
fsck from util-linux 2.20.1
fsck: fsck.ntfs: not found
fsck: error 2 while executing fsck.ntfs for /dev/sda5

How can I solve this problem?

Edit: ext partitions are now ok, but still problem with NTFS.

share|improve this question
    
Provide some more informations, e.g. look in boot.log, dmsg output, ... –  H.-Dirk Schmitt Mar 7 '13 at 19:06
    
I really don't know anything more :( –  Mostafa Shahverdy Mar 7 '13 at 19:07
    
what if you unmount and mount it again ? –  riimzzai Mar 7 '13 at 19:07
    
No success with that :( –  Mostafa Shahverdy Mar 7 '13 at 19:07
    
Try loading LiveUSB and fsck-ing the partition, i had to do this once, then reboot to Live, then fsck again, and it removed a RO setting. –  Thomas W. Mar 7 '13 at 19:09
add comment

2 Answers 2

up vote 2 down vote accepted

From the output of fsck, I can see you are using the Kernel NTFS driver which is a read-only driver.

You need to install (perhaps reinstall) the FUSE NTFS driver called NTFS 3G. The following command should solve your problem:

sudo apt-get install ntfs-3g

After that, either reboot or unmount and remount your NTFS partition. It should be mounted as read write. If it is not the case try forcing the type of file system with the following command:

sudo mount -t ntfs-3g /dev/sda5 /mnt

NOTE: AFAIK there are no fsck tool for NTFS partitions on Linux.

share|improve this answer
add comment

For my ext partition I used fsck and for my NTFS partitions I used a tool in ntfs-3g named ntfsfix. Now All is done.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.