Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my ubuntu 12.10 it didn't detect my graphic card. When I check the graphics in system settings>details it says none

I've downloaded my driver installer from the NVIDIA website, make it executable, then it ran but it say I doesn't install on a X server..

I read in a blog that I have to download drivers via the software center called jockey. After the installation I couldn't find my driver in the list..plus the problem it mentioned if I messed up then it will mess up my boot.

Can't I just use the file I got from nvidia to install it? Speaking of which is it necessary here since I don't play games here and would go for vmware and install my old windows OS there and play the game there instead.

Thanks

share|improve this question
    
That doesn't mean the card is not detected. Just use the built in installer, and don't forget to install linux-headers-generic first. –  mikewhatever Mar 7 '13 at 16:59

1 Answer 1

First put the downloaded NVIDIA driver in a folder which is easily accessible, for example on the Desktop.

Then switch to a virtual terminal using Ctrl+Alt+F1.

Enter your username and password to login.

Navigate to the folder which you've placed your driver in it, in this case it is Desktop:

cd ~/Desktop/

Now add the permission : execute to the installation file:

sudo chmod +x NVIDIAdriver*.run

replace NVIDIAdriver* with the actual name.

Now stop the X server as the error also mentions the same thing:

sudo service lightdm stop

Now you can go ahead and install the driver simply by typing this command:

sudo ./NVIDIAdriver*.run

Again replace NVIDIAdriver* with the drivers actual name.

Also, graphic cards don't support virtualization yet, so you won't get any good performance with WMware.

share|improve this answer
    
Thanks for the reply. So far I've had the linux-headers-generic installed via the software center. And for using the virtual terminal I always end up stuck in it and when I press ctrl+alt+del it restarts the system. I've tried using terminal so far nothing extraordinary appear when I did except that I end up with the virtual terminal and from there I tried entering the last terminal line: "sudo ./NVIDIAdriver*.run" but nothing..from there I couldn't get back to desktop. thanks –  Gabino Garcia Mar 8 '13 at 11:13
    
you can revert back by pressing Ctrl+Alt+f7 but before that you should enter the following command: sudo service lightdm start –  Soroosh129 Mar 8 '13 at 11:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.