Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm trying to install mysql-server 5.0. because I want to install a program which depend on this version. I've surfed the net to find a solution but none of them worked. I'm really disappointed. I tried "apt-get install mysql-server=5.0.96-0ubuntu3" but it said "Version '5.0.96-0ubuntu3' for 'mysql-server' was not found". I found this package at but I don't know how to use it. Is it a way that I can install it manually? please help me!

share|improve this question

2 Answers 2

Following the link you provided just click on your operating system's architecture (amd64 or i386) at the very bottom of the page. You will be redirected to a page with a download link for the corresponding .deb file (quite in the middle of the page). After you downloaded the file you can install it via sudo dpkg -i <path-to-file>.

If that doesn't work, the solutions given here should still work. Basically it's about installing old MySQL versions via Synaptic packet manager (which you can easily install by typing sudo apt-get install synaptic in a terminal if it isn't already installed). As mentioned in the post I linked above you might need to add a certain PPA for the specific version. You can do that with the command sudo add-apt-repository ppa:<user>/<ppa-name> - nevertheless be carefull of which sources you are going to trust. To find the right PPAs you will have to use a search engine.

share|improve this answer
thanks a lot. your answer was really helpful. now It starts installing but it gives me this error : E: mysql-server-5.0: subprocess installed post-installation script returned error exit status 1 .could you please tell me what should I do now? – Ghasedak Raha Mar 7 '13 at 19:12
You can find a solution to a similar problem here. I can't promise it will work, but it seems possible. – David Mar 8 '13 at 7:29

Download desired MySql generic binaries for your platform from Then just install using simple linux script(run from /share directory where setup binaries are placed ) , refer below for a script i used for years , worked for 5.1,5.5,5.6

Note : 1.MySql 5.6 does not come with default 'my.cnf' therefore be careful 2. Make sure you uninstall any exiting MySql setup



if test -f $DOWNLOAD_DIR/mysql-enterprise-5.1.55-linux-x86_64-glibc23.tar.gz; then
    echo "Starting MySql 64 bit install..."
elif test -f $DOWNLOAD_DIR/mysql-enterprise-5.1.55-linux-i686-glibc23.tar.gz; then
    echo "Starting MySql 32 bit install..."
    echo "installation tar.gz not found, quitting..."
    exit 2

groupadd mysql
useradd -g mysql mysql
cd /usr/local
gunzip < $DOWNLOAD_DIR/$ZIP_FILE | tar xf -
ln -s /usr/local/$MYSQL_DIR mysql
cd mysql
chown -R mysql .
chgrp -R mysql .
scripts/mysql_install_db --user=mysql
chown -R root .
chown -R mysql data
# bin/mysqld_safe --user=mysql &
cp /usr/local/$MYSQL_DIR/support-files/mysql.server /etc/init.d/mysql
#cp $DOWNLOAD_DIR/mysql-cnf.txt /etc/my.cnf
chmod 755 /etc/init.d/mysql
cp support-files/mysql-log-rotate /etc/logrotate.d
update-rc.d mysql defaults
/etc/init.d/mysql start
# create path links for most commonly used executables
ln -s /usr/local/mysql/bin/mysql /usr/bin/mysql
ln -s /usr/local/mysql/bin/mysqladmin /usr/bin/mysqladmin
ln -s /usr/local/mysql/bin/mysqldump /usr/bin/mysqldump
/usr/local/mysql/bin/mysqladmin -u root password 'xxxxx'
echo "Done"
exit 0
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.