Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried installing the packages as below

apt-get install libcurl4-gnutls-dev libexpat1-dev gettext \
  libz-dev libssl-dev

then I got this error

    root@ip-10-233-139-125:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      openmrs
    Suggested packages:
      tomcat6-admin lcab cabextract
    The following NEW packages will be installed:
      openmrs
    0 upgraded, 1 newly installed, 0 to remove and 137 not upgraded.
    1 not fully installed or removed.
    Need to get 0 B/34.1 MB of archives.
    After this operation, 34.9 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    WARNING: The following packages cannot be authenticated!
      openmrs
    Install these packages without verification [y/N]? y
    dpkg: error processing /var/cache/apt/archives/openmrs_1.6.1_all.deb (--unpack):
     unable to open file '/var/lib/dpkg/tmp.ci//.svn': Is a directory
    No apport report written because MaxReports is reached already
                                                                  Errors were encountered while processing:
     /var/cache/apt/archives/openmrs_1.6.1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

then I tried

root@ip-10-248-109-175:~# sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of sana:
 sana depends on openmrs; however:
  Package openmrs is not installed.
dpkg: error processing sana (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 sana

I removed the directory sana in /opt/ as I don't want that. I tried some other

share|improve this question
    
Where does openmrs come from? Have you added an external repository? Which one? –  mikewhatever Mar 7 '13 at 13:04
    
I added openmrs,java softwareusing tomcat but now I uninstalled tomcat also I m not finding openmrs with command locate openmrs @mikewhatever –  ReThink Mar 7 '13 at 13:14
    
Run sudo apt-get clean to clean cached .debs. –  mikewhatever Mar 7 '13 at 13:18
    
this is working,can you make this solution,so that I will vote that. –  ReThink Mar 7 '13 at 13:31
    
Glad it helped. ...answer posted. –  mikewhatever Mar 7 '13 at 15:00
add comment

1 Answer 1

up vote 0 down vote accepted

Apparently, cleaning the cached packages was a solution, and the following command does just that.

sudo apt-get clean
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.